手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Ubuntu 12.04 下安装Code::Blocks

[日期:2012-10-28] 来源:Linux社区  作者:sf_chipan [字体: ]

在联网情况下,在Ubuntu 12.04 下输入以下指令进行安装。

1.安装基本编译环境

$sudo apt-get install build-essential

$sudo apt-get install gdb

2.安装codeblock

$sudo apt-get install codeblocks

$sudo apt-get install codeblocks-dbg

$sudo apt-get install wxformbuilder

($sudo apt-get install contrib,原文作者解释到,这是安装wxSmith,如果不安装就算是使用wxfb。)

或者直接在Ubuntu软件中心里,关键字搜索codeblock就能找到codeblock进行安装。

我是在软件中心安装的,然后又在终端安装了codeblocks-dbg,目前还不知道这个事干什么用的。就先装上了。

3.安装wxWidgets

$sudo apt-get install libwxbase2.8

$sudo apt-get install libwxbase2.8-dev

$sudo apt-get install libwxgtk2.8-0

$sudo apt-get install libwxgtk2.8-dev

$sudo apt-get install libwxgtk2.8-dbg

$sudo apt-get install wx-common

$sudo apt-get install wx2.8-headers

$sudo apt-get install wx2.8-i18n

($sudo apt-get install wx2.8-examples

$sudo apt-get install wx2.8-doc

以上两个为文档,选装)

4.安装完之后,打开Code::Blocks就能直接使用了。

我没有进行编译器路径的设置,只是把编译器选择为GCC而已,使用#include时要用到的一些头文件还是能找到的。在最后的第一个参考文章中说要进行基本编译运行环境的配置,否则工程编译无法通过。就我门前的学习还用不到工程文件,所以就没有配置。

5.关于Code::Blocks的其他设置请参见。

Ubuntu下CodeBlock开发环境配置 http://www.linuxidc.com/Linux/2012-10/73117.htm

6*.安装过程中遇到的问题:

code::blocks官网上有一篇文章叫:Instal Code::Blocks nightly build on ubuntu。

在安装到它提示get the latest nightly build时,给了一个链接,要去去安装nightly build。结果在那个链接里面找了很多版本的都没有找到linux版本的,全都时windows版本。然后又注意到标题其实还有个nightly build,于是就去查了一下这个nightly build是个什么东西。

nightly build:

每日构建(Nightly Build,也叫Daily Build),是将一个软件项目的所有最新代码取出,从头开始编译,链接,运行测试软件包对代码进行单元测试并对主要功能进行测试,发现错误并报告错误的完整过程。通常由工具自动完成。每日构建是连续集成的一个最佳实践,它要求每天至少构建软件一次。因为对于许多大型项目来说,每次构建花掉的时间可能高达几个小时,在白天进行构建可能会消耗过多的计算机资源,对开发造成一定的影响,所以许多大型项目的每日构建是在夜间无人工作或者人比较少的时候进行的。前提是员工check in 最新的code到配置库中。所以可以把daily build 戏称为nightly build。然后在第二天上班时分析build的log,找出error并mail给所属模块负责人,敦促解决(如果这一步能自动完成就更完美了)。按照上面的解释,daily build 译为“每日构建”,是很合适的。但daily build的另一个重要功能就是验证软件中各模块关系是否正确,也可称为“每日集成”。

这个nightly build目前也用不到,就先不弄了。

Code::Blocks 的详细介绍请点这里
Code::Blocks 的下载地址请点这里

更多Ubuntu相关信息见Ubuntu 专题页面 http://www.linuxidc.com/topicnews.aspx?tid=2

linux
本文评论   查看全部评论 (1)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款
第 1 楼
* kevinkong 发表于 2013/12/3 21:13:20
注意安装wxsmith到话,其实是sudo apt-get install codeblocks-contrib