你好,游客 登录 注册 搜索
背景:
阅读新闻

OAuth及OpenID隐蔽重定向漏洞

[日期:2014-05-10] 来源:Linux社区  作者:Linux [字体: ]

发布日期:2014-05-02
更新日期:2014-05-10

受影响系统:
OAuth OAuth 2.0
 OpenID OpenID
描述:
--------------------------------------------------------------------------------
OAUTH协议为用户资源的授权提供了一个安全的、开放而又简易的标准。OpenID 是一个以用户为中心的数字身份识别框架,它具有开放、分散性。OAuth和OpenID协议目前被广泛用于各大公司——如微软、Facebook、Google、Yahoo、VK、PayPal、GitHub、LinkedIn、QQ、Weibo等。
 
OAUTH及OpenID在实现上存在隐蔽重定向漏洞,即攻击者在受影响站点创建一个弹出式登录窗口,然后诱使用户登录,窃取个人数据,将用户重定向到攻击者控制的网站。
 
<*来源:Wang Jing
 
  链接:http://www.cnet.com/news/serious-security-flaw-in-oauth-and-openid-discovered/
        http://thehackernews.com/2014/05/nasty-covert-redirect-vulnerability.html?m=1
 *>

建议:
--------------------------------------------------------------------------------
临时解决方法:
 
* 请对第三方OAuth的弹出式登录窗口保持警惕。
 
厂商补丁:
 
OAuth
 -----
 目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
 
http://oauth.net/2/

本文永久更新链接地址http://www.linuxidc.com/Linux/2014-05/101507.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款