你好,游客 登录 注册 搜索
背景:
阅读新闻

Linux编译安装GCC 5.1.0

[日期:2015-05-04] 来源:Linux社区  作者:Linux [字体: ]

Linux下编写C/C++程序自然缺不了一个优秀的编译器,Linux下比较常见的自然是GCC了。2015年4月下旬GCC也出到了5.1.0版本,对于C++11/14也有了更好的支持了。因为最近在学习OpenMP, Gcc-5.1.0支持OpenMP4.0最新版本。所以,今天我们就来说说GCC的编译安装,安装的版本正是最新的5.1.0。下面我们进入正题(建议整个过程以root用户进行):

1.下载GCC源码:

wget ftp://mirrors.kernel.org/gnu/gcc/gcc-5.1.0/gcc-5.1.0.tar.gz2.解压:

tar -zxvf gcc-5.1.0.tar.gz3.下载编译所需依赖项:

  cd gcc-5.1.0                    //进入解包后的gcc文件夹
  ./contrib/download_prerequisites                  //下载依赖项
  cd ..                          //返回上层目录4.建立编译输出目录:


  mkdir gcc-build-5.1.05.进入输出目录,执行以下命令,并生成makefile文件:

  cd gcc-build-5.1.0
  ../gcc-5.1.0/configure --enable-checking=release --enable-languages=c,c++ --disable-multilib

6.编译:

make -j4接下来就是等待了,整个过程大约40分钟左右。PS:最好不要在编译过程中再去做别的什么事,整个过程CPU都是满载的,要是莫名终止了,后面麻烦事也不少。

7.安装:

编译结束以后,我们就可以执行安装了:

make install8.检查版本:

gcc --version
或gcc -vroot@Ubuntu:~/下载/gcc-build-5.1.0$ gcc --version
gcc (GCC) 5.1.0
Copyright © 2015 Free Software Foundation, Inc.
本程序是自由软件;请参看源代码的版权声明。本软件没有任何担保;
包括没有适销性和某一专用目的下的适用性担保。

Linux升级GCC 4.8.1清晰简明教程(Ubuntu 12.04 64位版为例)  http://www.linuxidc.com/Linux/2014-04/99583.htm

CentOS 6.4中编译安装GCC 4.8.1 + GDB 7.6.1 + Eclipse 在CentOS 6.4中编译安装GCC 4.8.1 + GDB 7.6.1 + Eclipse

Ubuntu下Vim+GCC+GDB安装及使用 http://www.linuxidc.com/Linux/2013-01/78159.htm

Ubuntu下两个GCC版本切换 http://www.linuxidc.com/Linux/2012-10/72284.htm

CentOS6.5升级手动安装GCC4.8.2  http://www.linuxidc.com/Linux/2015-01/112595.htm

GCC 的详细介绍请点这里
GCC 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2015-05/116996.htm

linux
相关资讯       Linux安装GCC  GCC 5 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款