你好,游客 登录 注册 搜索
背景:
阅读新闻

Amber11+AmberTools1.5+CUDA加速 安装总结

[日期:2015-07-24] 来源:Linux社区  作者:Linux [字体: ]

以下安装方法是根据分子模拟论坛网友的一些以前的帖子,进行了综合与总结,只要操作正确100%可以安装并测试成功。考虑到Amber11一般要安装在集群上使用,所以安装时采用intel的编译器,Openmpi并行器。Amber11软件需要购买获得使用license,AmberTools可以到www.ambermd.org免费下载。

安装环境:
Dell Precision Workstation T3400 à Q9550 8G ECC à Geforce GTX 560ti (2GB)
CentOS 6.2 X86-64 à Intel Compilers(iforc, icc, iMKL) à Openmpi-1.4.3
CUDA Toolkit 4.0

1.
安装intel compilers
从intel官方网站上下载非商业版本的intel C++ compiler (icc) and intel fortran compiler (ifort) 当前的版本为2011.6.233,同时会获得一个非商业的licenses (one year available),会发到你申请时填写的email中)。
下载地址:
http://software.intel.com/en-us/articles/non-commercial-software-download/
解压,进入解压后的目录,进行安装:
cd /home/soft/l_fcompxe_2011.6.233
./install.sh
#激活产品选项时选择"Use a license file"
#安装选项中不需要的部分如Intel Debugger等可以去掉,但里面intel MKL应保留。
#用相同的方法安装icc (l_ccompxe_2011.6.233), 同样安装选项中只选择Intel C++ Compiler,
#为intel设置环境变量 gedit .bashrc
source /opt/intel/composer_xe_2011_sp1.6.233/bin/compilervars.sh intel64
export MKL_HOME=/opt/intel/mkl

2. 安装 nVidia toolkit
# 到Nvidia网站上下载"CUDA Toolkit 4.0" (CUDA Toolkit for RedHat Enterprise Linux 6.0)
下载地址:http://developer.nvidia.com/cuda-toolkit-40 并安装
./cudatoolkit_4.0.17_linux_64_rhel6.0.run
#为CUDA设置环境变量 gedit .bashrc
export PATH=$PATH:/usr/local/cuda/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cuda/lib64:/usr/local/cuda/lib
export CUDA_HOME=/usr/local/cuda

3. 解压Amber与AmberTools
#首先为Amber11设置环境变量 gedit .bashrc
export AMBERHOME=/home/soft/amber11
export PATH=$PATH:/home/soft/amber11/bin
export DO_PARALLEL="mpirun -np 4"
#解压Amber11.tar.bz2到目录:/home/soft/amber11, 再解压 AmberTools-1.5.tar.bz2到相同的目录:/home/soft/amber11 (全部替换),
#集成自 l_fcompxe_2011.6.233里的intel MKL,安装时Amber时会有个错误提示,所以在进行AmberTools安装前要改一下/home/soft/amber11/AmberTools/src/configure文件,查找 "em64t" : mkll="$MKL_HOME/lib/em64t". 将em64t换成"intel64".

4. 为Amber11和AmberTools打补丁
#为AmberTools打补丁:到Amber网站上下载 "bugfix.all" for AmberTools1.5, 放在AMBERHOME目录下。下载地址:http://ambermd.org/bugfixesat.html
cd $AMBERHOME
patch -p0 -N < bugfix.all
#为Amber11打补丁:到Amber网站上下载bugfix package of Amber11和apply_bugfix.x,下载地址:http://ambermd.org/bugfixes11.html
chmod 700 apply_bugfix.x
./apply_bugfix.x bugfix.1to17.tar.bz2

5. 安装串行的AmberTools 1.5
cd /home/soft/amber11/AmberTools/src
./configure intel
make serial
#这一步大约要10多分钟,比较耗时时间。测试一下
cd ../test
make test
#检查一下check.diff 文件看看有无错误出现,该文件位于:
(/home/soft/amber11/AmberTools/test/logs/test_at_serial)

6. 安装串行的 Amber11
cd /home/soft/amber11
./AT15_Amber11.py
cd src
make serial
#测试方法:
cd /home/soft/amber11/test
make test
#同样在/home/soft/amber11/test/logs/test_amber_serial目录下你可以找到check.diff文件

7. 安装CUDA加速的PMEMD
# 目前Amber11中,只有PMEMD支持CUDA加速
cd /home/soft/amber11/AmberTools/src
make clean
./configure -cuda intel
cd /home/soft/amber11/
./AT15_Amber11.py
cd src
make clean
make cuda
#测试方法:
cd /home/soft/amber11/test/
./test_amber_cuda.sh
同样在/home/soft/amber11/test/logs/test_amber_cuda目录里有log文件。

8. Install openmpi-1.4.3 within AmberTools
#下载openmpi-1.4.3.tar.bz2(http://www.open-mpi.org/)
# cp openmpi-1.4.3.tar.bz2 AmberTools/src

tar -zxvf openmpi-1.4.3.tar.bz2
./configure_openmpi intel
#添加openmpi的环境变量
export MPI_HOME=$AMBERHOME/AmberTools
export PATH=$AMBERHOME/AmberTools/exe:$PATH
export LD_LIBRARY_PATH=$AMBERHOME/AmberTools/lib:$LD_LIBRARY_PATH
#这时,openmpi还是不能生效,利用which mpirun发现intel里集成了mpir,所以将intel集成的mpi目录改一个名子,让openmpi生效。

9. 安装并行版本的Amber11
cd /home/soft/amber11/AmberTools/src
./configure –mpi intel
cd /home/soft/amber11
./AT15_Amber11.py
cd src
make clean
make parallel
#测试方法:
cd /home/soft/amber11/test
make test.parallel

10. 重新单独安装openmpi
#安装目录: /home/soft/openmpi
#将之前安装在ambertools目录中的openmpi环境变量屏蔽掉重新安装,并添加.bashrc
# openmpi
export MPI_HOME=/home/soft/openmpi
export PATH=/home/soft/openmpi/bin:$PATH
export LD_LIBRARY_PATH=/home/soft/openmpi/lib:$LD_LIBRARY_PATH
#这一步不是必须的,只是为了以后再安装别的并行软件如gromacs时方便

11. Copy /boot/.bashrc to your own .bashrc
# 以上安装是在root下进行的,也可以在普通用户下进行安装
#最终的普通用户下的.bashrc 文件:
# /home/yuanxh/.bashrc
#___________________________________________________________
# intel icc
source /home/soft/intel/composer_xe_2011_sp1.6.233/bin/compilervars.sh intel64
export MKL_HOME=/home/soft/intel/mkl
#________________________________________________________________
# amber11
export AMBERHOME=/home/soft/amber11
export PATH=$PATH:/home/soft/amber11/bin
export DO_PARALLEL="mpirun -np 4"
#________________________________________________________________
# openmpi
export MPI_HOME=/home/soft/openmpi
export PATH=/home/soft/openmpi/bin:$PATH
export LD_LIBRARY_PATH=/home/soft/openmpi/lib:$LD_LIBRARY_PATH
#________________________________________________________________
# fftw
export CPPFLAGS=-I/opt/fftw3/include
export LDFLAGS=-L/opt/fftw3/lib
export FFTW_LOCATION=/opt/fftw3
export FFTW3F_LIBRARIES=/opt/fftw3/lib
export FFTW3F_ROOT_DIR=/opt/fftw3
export FFTW3F_INCLUDE_DIR=/opt/fftw3/include
#________________________________________________________________
# Gromacs-4.5.5
export PATH=$PATH:/home/soft/gmx/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/soft/gmx/lib
#________________________________________________________________
# VMD
export PATH=$PATH:/home/soft/vmd/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/soft/vmd/lib
#________________________________________________________________

12.注意事项与其他说明

*注1:如果机器是64位的,那么安装的软件也要求是64位的。
*注2:查看机器是什么系统的,例如:mips、intel、 opteron。编译器根据不同的CPU类型有不同的选择,intel核心建议使用intel的编译器,opteron核心建议使用pgi的编译器。强烈不推荐gnu的编译器,运行效率太低。Opteron一般不支持intel编译器,所以可选择gnu或pgi编译器。保证编译并行库和AMBER时使用相同的编译器和相同的编译选项。
*注3:编译时要使用相同的编译选项,要么都编成32位的,要么都编成64位的。不能并行库编成32位,而AMBER编成64位,反之亦然。
*注4:并行库有OpenMPI,LAM和MPICH等,OpenMPI比较好用。同时,MPICH支持1000兆网速,不支持Inifiband高速网,在高性能机上,采用并行,选择OpenMPI,如果在一般的集群,可采用MPICH
*注5:如果采用pgi编译器,有一个针对不同CPU的选项(-tp),要格外注意,编译前可以使用man帮助系统查看一下。AMBER9所附带的netcdf库似乎有个问题。这个库的Makefile文件独立于AMBER生成的config.h,因而在某些体系下会出现配置不一致的情况,导致链接时找不到库函数的定义。解决办法就是手工修改netcdf目录下的Makefile文件,使它的编译器、编译和链接选项与AMBER的生成文件一致。这个问题好像只在pgi/opteron的情况下遇见过。
*注6.注意测试并行版前要设置一下环境变量,比如: export DO_PARALLEL =‘mpirun -np 4’ ,根据不同的机器其实际参数不一样。
*注7:configure_openmpi所支持的OPENMPI版本为1.4.2和1.4.3
*注8:MKL这次支持10.0或11.0系列版本。如果使用的是9.0系列或更早的版本,在configure的时候需要加上-oldmkl参数
*注9:并行器的参数进行了简化,不管用什么并行器,参数均为-mpi(前提是设置好环境变量)
*注10: PMEMD在Amber11中不用单独安装

Caffe + Ubuntu 14.04 64bit + CUDA 6.5 配置说明  http://www.linuxidc.com/Linux/2015-04/116444.htm

Ubuntu 14.04 安装配置CUDA  http://www.linuxidc.com/Linux/2014-10/107501.htm

Ubuntu 12.04配置NVIDIA CUDA5.5实录  http://www.linuxidc.com/Linux/2014-10/107502.htm

Ubuntu安装Theano+CUDA  http://www.linuxidc.com/Linux/2014-10/107503.htm

关于Ubuntu 12.04 下 CUDA5.5 的安装请参看如下链接 Ubuntu 12.04 安装 CUDA-5.5

Ubuntu下CUDA(含GPU卡驱动)安装过程  http://www.linuxidc.com/Linux/2015-07/120456.htm

Ubuntu 14.04 安装 NVIDIA 驱动+CUDA+MATLAB  http://www.linuxidc.com/Linux/2015-07/120457.htm

本文永久更新链接地址http://www.linuxidc.com/Linux/2015-07/120485.htm

linux
相关资讯       CUDA  Amber11 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款