你好,游客 登录 注册 搜索
背景:
阅读新闻

VLC Media Player 'src/network/httpd.c'跨站脚本漏洞

[日期:2015-08-18] 来源:Linux社区  作者:Linux [字体: ]
VLC Media Player 'src/network/httpd.c'跨站脚本漏洞


发布日期:2014-03-19
更新日期:2015-08-18

受影响系统:

VideoLAN VLC Media Player < 2.2.0

描述:


BUGTRAQ  ID: 66307
CVE(CAN) ID: CVE-2014-9743

VLC Media Player是多媒体播放器。

VideoLAN VLC Media Player 2.2.0之前版本,Web接口中network/httpd.c的httpd_HtmlError函数存在跨站脚本漏洞,可使远程攻击者通过路径信息,利用此漏洞注入Web脚本或HTML。

<*来源:Francesco Perna
        Pietro Minniti
  *>

建议:


厂商补丁:

VideoLAN
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://git.videolan.org/?p=vlc.git;a=commit;h=fe5063ec5ad1873039ea719eb1f137c8f3bda84b

Ubuntu 12.04安装最新版VLC2.0.2 http://www.linuxidc.com/Linux/2012-07/64542.htm

Ubuntu 14.04 用户如何安装 VLC 2.2.0 http://www.linuxidc.com/Linux/2014-03/98913.htm

CentOS 6.5 下yum安装VLC  http://www.linuxidc.com/Linux/2015-04/116262.htm

Ubuntu 14.04小技巧:显示VLC(VLC media player)的通知 http://www.linuxidc.com/Linux/2014-07/103921.htm

Fedora 22 用户如何安装 VLC media player http://www.linuxidc.com/Linux/2015-06/118401.htm

VLC media player 的详细介绍请点这里
VLC media player 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2015-08/121876.htm

linux
相关资讯       VLC漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款