你好,游客 登录 注册 搜索
背景:
阅读新闻

LibreSSL缓冲区溢出漏洞(CVE-2015-5334)

[日期:2015-10-21] 来源:Linux社区  作者:Linux [字体: ]
LibreSSL缓冲区溢出漏洞(CVE-2015-5334)


发布日期:2015-10-15
更新日期:2015-10-21

受影响系统:

LibreSSL LibreSSL 2.0.0 - 2.3.0

描述:


CVE(CAN) ID: CVE-2015-5334

LibreSSL是OpenSSL加密软件库的一个分支,是安全套接层(SSL)和传输层安全(TLS)协议的开源实现。

LibreSSL的OBJ_obj2txt()函数在越界写NULL结束符,在实现上存在缓冲区溢出漏洞,远程攻击者利用此漏洞可执行远程代码。

<*来源:LibreSSL
 
  链接:http://www.securityfocus.com/archive/1/536692
*>

建议:


厂商补丁:

LibreSSL
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.libressl.org/

OpenSSL TLS心跳读远程信息泄露漏洞 (CVE-2014-0160) http://www.linuxidc.com/Linux/2014-04/99741.htm

OpenSSL严重bug允许攻击者读取64k内存,Debian半小时修复 http://www.linuxidc.com/Linux/2014-04/99737.htm

OpenSSL “heartbleed” 的安全漏洞 http://www.linuxidc.com/Linux/2014-04/99706.htm

通过OpenSSL提供FTP+SSL/TLS认证功能,并实现安全数据传输 http://www.linuxidc.com/Linux/2013-05/84986.htm

LibreSSL 的详细介绍请点这里
LibreSSL 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2015-10/124350.htm

linux
相关资讯       LibreSSL  LibreSSL 漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款