你好,游客 登录 注册 搜索
背景:
阅读新闻

Linux 下编译FFmpeg 支持x264, x265

[日期:2016-04-05] 来源:Linux社区  作者:mengfanrong [字体: ]

1. 前言

本教程涉及的ffmpeg, x264, x265

2. 环境依赖

2.1 删除系统中安装的ffmpeg等库
sudo apt-get --purge remove ffmpeg mplayer x264 x265

2.2 安装依赖库
sudo apt-get update
sudo apt-get -y --force-yes install autoconf automake build-essential libass-dev libfreetype6-dev libgpac-dev \
  libsdl1.2-dev libtheora-dev libtool libva-dev libvdpau-dev libvorbis-dev libxcb1-dev libxcb-shm0-dev \
  libxcb-xfixes0-dev pkg-config texi2html zlib1g-dev

注: server版本号可忽略
libsdl1.2-dev libva-dev libvdpau-dev libxcb1-dev libxcb-shm0-dev libxcb-xfixes0-dev

2.3 下载源码

(1) ffmpeg
git clone git://source.ffmpeg.org/ffmpeg.git ffmpeg

 (2) x264<pre name="code" class="plain"><pre name="code" class="plain">git clone git://git.videolan.org/x264.git

(3) x265hg clone https://bitbucket.org/multicoreware/x265

(4) yasm
yasm 是x86平台的一个汇编优化器, 可以加快ffmpeg x264的编译
wget http://www.tortall.net/projects/yasm/releases/yasm-1.3.0.tar.gz
tar xzvf yasm-1.3.0.tar.gz

3. 编译

3.1 配置编译输出文件夹
export FFMPEG_PATH="YOUR_PATH"
export PATH="$FFMPEG_PATH/bin:$PATH"
比如我输出文件夹为$HOME/ffmpeg_2.6.3/build_out
那么:
export FFMPEG_PATH="$HOME/ffmpeg_2.6.3/build_out"

3.1 yasm
cd yasm-1.3.0
./configure --prefix="$HOME/"
make
make install

或者安装已有的库(yasm version ≥ 1.3.0)
sudo apt-get install yasm

3.2 x264

在配置ffmpeg config时须要增加--enable-gpl和--enable-libx264
cd x264*
./configure --prefix="$FFMPEG_PATH" --enable-shared --enable-static
make -j4
make install
make clean
或者安装已有的库(yasm version ≥ 1.3.0)sudo apt-get install libx264-dev

3.3 x265
cd x265/build/linux
cmake -G "Unix Makefiles" -DCMAKE_INSTALL_PREFIX="$FFMPEG_PATH" -DENABLE_SHARED:bool=off ../../source
make -j4
make install
make clean
</tt></span>

3.4 aac

在配置ffmpeg config时须要增加--enable-libfdk_aac(假设开启--enable-gpl同一时候须要开启--enable-nonfree )
PKG_CONFIG_PATH="$FFMPEG_PATH/lib/pkgconfig" ./configure \
  --prefix="$FFMPEG_PATH" \
  --pkg-config-flags="--static" \
  --extra-cflags="-I$FFMPEG_PATH/include" \
  --extra-ldflags="-L$FFMPEG_PATH/lib" \
  --enable-gpl \
  --enable-libass \
  --enable-libfaac \
  --enable-libfreetype \
  --enable-libmp3lame \
  --enable-libtheora \
  --enable-libvorbis \
  --enable-libx264 \
  --enable-libx265 \
  --enable-nonfree \
  --enable-shared \
  --enable-postproc \
  --enable-x11grab \
  --enable-bzlib \
  --enable-libxvid \
  --enable-zlib \
  --disable-debug

4. 将ffmpeg加入到环境变量

4.1 将ffmpeg加入到环境变量
vim ~/.bashrc
在最后加入

export FFMPEG_PATH="/home/guohe/workspace/ffmpeg_2.6.3/build_out"
export PATH="$FFMPEG_PATH/bin:$PATH"

4.2 加入链接库

编译完毕之后调用 ffmpeg 会出现 error while loading shared libraries: xxx

解决这样的问题有2中方法:

(1) 改动/etc/ld.so.conf
vim /etc/ld.so.conf

在最后加入$FFMPEG_PATH/lib

然后运行
sudo ldconfig

(2) 改动LD_LIBRARY_PATH

vim ~/.bashrc
在最后加入export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$FFMPEG_PATH/ib

Linux下编译FFmpeg之下载源文件并编译 http://www.linuxidc.com/Linux/2012-02/54565.htm

Linux 编译升级 FFmpeg 步骤 http://www.linuxidc.com/Linux/2013-08/88190.htm

CentOS 5.6 上安装 FFMPEG http://www.linuxidc.com/Linux/2011-09/42793.htm

Ubuntu下安装FFmpeg http://www.linuxidc.com/Linux/2012-12/75408.htm

Ubuntu 12.04下编译ffmpeg  http://www.linuxidc.com/Linux/2013-02/78857.htm

Ubuntu 14.04下PPA安装FFmpeg 2.2.2  http://www.linuxidc.com/Linux/2014-05/101322.htm

FFmpeg 的详细介绍请点这里
FFmpeg 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2016-04/129858.htm

linux
相关资讯       Linux下编译FFmpeg 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款