你好,游客 登录 注册 搜索
背景:
阅读新闻

Python数据科学安装Numby,pandas,scipy,matpotlib等(IPython安装pandas)

[日期:2016-08-10] 来源:Linux社区  作者:dream_an [字体: ]

Python数据科学安装Numby,pandas,scipy,matpotlib等(IPython安装pandas)

如果还没有本地安装Python、IPython、notebook等请移步

上篇 Python,IPython,qtconsole,Notebook,Jupyter快速安装教程

本教程是安装二进制文件,以Windows10 64位操作系统为例,但是二进制文件对应其他Linux和mac os也同样试用。

在开始安装之前,请注意以下前提条件。否则,会出现各种问题。

默认机器上已经安装了Python3.x、IPython和notebook,还有visual studio2015(如果没有会编译出错,需要安装VS组件)

正式开始数据科学之路:

Numby,pandas,scipy等被称为科学栈,这些科学栈都是有先后的依赖关系。
简言之,安装某个科学栈,它可能需要其他科学栈做支持。
例如:安装Pandas
需要NumPy,dateutil,pytz,setuptools(后三个如果是Python3.5的话默认已经安装)

所以安装过程很简单

三步:
第一步:确定要安装的科学栈为目的科学栈(如想安装pandas)
第二步:确定要安装科学栈需要的前提(如需要NumPy,dateutil,pytz,setuptools)
第三步:安装目的科学栈(安装pandas)

实际安装实例(以Windows10 64位下安装pandas为例):

1.下载pandas对应的机器位数和Python版本

2.查看需要的前提(Requies)

Requires numpy, dateutil, pytz, setuptools,
根据网页链接依次下载,安装办法如步骤3
如果想知道是否已经安装某组件,如想知道机器是否已经安装dateutil可以在CMD输入以下命令

pip install dateuil

3.安装pandas二进制文件(我的把pandas文件下载到了F盘download文件夹下)

pip install F:\download\pandas-0.17.1-cp35-none-win_amd64.whl

如此,你可以安装任意的Numby,pandas,scipy,matpotlib等科学栈,只要根据提示安装前提的依赖即可顺利安装!

授人以鱼不如授人以渔,开始你的数据科学之路吧

本文永久更新链接地址http://www.linuxidc.com/Linux/2016-08/134105.htm

linux
相关资讯       IPython  SciPy  Numby  pandas  matpotlib 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款