你好,游客 登录 注册 搜索
背景:
阅读新闻

gcc: error trying to exec 'cc1plus': execvp: no such file or directory

[日期:2016-08-24] 来源:Linux社区  作者:mydebug [字体: ]

最近在安装OpenCV cmake的时,出现gcc: error trying to exec 'cc1plus': execvp: no such file or directory的错误。

导致问题的原因可能是因为没有安装 gcc 或者 g++,也可能是已安装的 gcc 和 g++ 版本不兼容 ,先解决方法如下:

  首先检查 gcc 或者 g++ 是否已经安装,若未安装 sudo apt-get install gcc(g++)
  再用 gcc -v 和 g++ -v 分别检查 gcc 和 g++ 的版本号, 看版本号是否一致,若不一致,请安装同一个版本的gcc和g++。

  我遇到的问题是因为版本号不兼容导致的(gcc 版本号为 4.8,g++ 版本号为 5.2)。
  所以需要将版本统一,将g++降为4.8版本的(sudo apt-get install g++-4.8),之后还需要ln链接一下。

  cd到/usr/bin目录下(Ubuntu 64位):
    sudo  ln  -sf  g++-4.8  g++
    sudo  ln  -sf  g++-4.8  x86_64-linux-gnu-g++
    sudo  ln  -sf  gcc-4.8  gcc
    sudo  ln  -sf  gcov-4.8 gcov
    sudo  ln  -sf  gcc-4.28  x86_64-linux-gnu-gcc

 cmake 成功!

Linux升级GCC 4.8.1清晰简明教程(Ubuntu 12.04 64位版为例)  http://www.linuxidc.com/Linux/2014-04/99583.htm 

Ubuntu 14.04 LST安装GCC 4.1.2  http://www.linuxidc.com/Linux/2016-06/132040.htm

Ubuntu下Vim+GCC+GDB安装及使用 http://www.linuxidc.com/Linux/2013-01/78159.htm 

Ubuntu下两个GCC版本切换 http://www.linuxidc.com/Linux/2012-10/72284.htm 

CentOS6.5升级手动安装GCC4.8.2  http://www.linuxidc.com/Linux/2015-01/112595.htm 

GCC 的详细介绍请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2016-08/134546.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款