你好,游客 登录 注册 搜索
背景:
阅读新闻

PHP 'ext/standard/file.c' 远程拒绝服务漏洞(CVE-2016-5096)

[日期:2016-09-12] 来源:Linux社区  作者:Linux [字体: ]
PHP 'ext/standard/file.c' 远程拒绝服务漏洞(CVE-2016-5096)


发布日期:2016-05-25
更新日期:2016-09-12

受影响系统:

PHP PHP < 5.5.36
PHP PHP 5.6.x < 5.6.22

描述:


BUGTRAQ  ID: 90861
CVE(CAN) ID: CVE-2016-5096

PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。

PHP < 5.5.36, 5.6.x < 5.6.22版本中,ext/standard/file.c/fread函数存在整数溢出安全漏洞。远程攻击者利用此漏洞可造成拒绝服务。

<*来源:fernando
  *>

建议:


厂商补丁:

PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:



URL:http://www.openwall.com/lists/oss-security/2016/05/26/3
http://php.net/ChangeLog-5.php
https://bugs.php.net/bug.php?id=72114
https://github.com/php/php-src/commit/abd159cce48f3e34f08e4751c568e09677d5ec9c?w=1
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

本文永久更新链接地址http://www.linuxidc.com/Linux/2016-09/135134.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款