你好,游客 登录 注册 搜索
背景:
阅读新闻

libarchive 多个整数溢出漏洞(CVE-2015-8931)

[日期:2016-09-21] 来源:Linux社区  作者:Linux [字体: ]
libarchive 多个整数溢出漏洞(CVE-2015-8931)


发布日期:2016-09-18
更新日期:2016-09-21

受影响系统:

libarchive libarchive <= 3.2.0

描述:


CVE(CAN) ID: CVE-2015-8931

libarchive是多种格式的存档文件及压缩库。

libarchive 3.2.0及更早版本,archive_read_support_format_mtree.c内的get_time_t_max、get_time_t_min函数存在安全漏洞。远程攻击者通过构造的mtree文件,可进行安全攻击。

<*来源:vendor
  *>

建议:


厂商补丁:

libarchive
----------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/libarchive/libarchive/issues/539

http://www.ubuntu.com/usn/USN-3033-1

本文永久更新链接地址http://www.linuxidc.com/Linux/2016-09/135385.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款