你好,游客 登录 注册 搜索
背景:
阅读新闻

Samba 堆缓冲区溢出漏洞(CVE-2016-2123)

[日期:2017-01-21] 来源:Linux社区  作者:Linux [字体: ]
Samba 堆缓冲区溢出漏洞(CVE-2016-2123)


发布日期:2017-01-20
更新日期:2017-01-21

受影响系统:

Samba Samba 4.0.0 - 4.5.2

描述:


BUGTRAQ  ID: 94970
CVE(CAN) ID: CVE-2016-2123

Samba是在Linux和UNIX系统上实现SMB协议的一个免费软件,由服务器及客户端程序构成。

Samba 4.0.0 - 4.5.2版本在NDR数据处理中存在安全漏洞,此漏洞位于ndr_pull_dnsp_name例程中,可使用户通过LDAP对dnsRecord 属性写操作,导致在当前进程上下文中执行任意代码。

<*来源:c4c1234757b4f1e468a29d480d78f21b
        Frederic Besler
        c692f9f0933f03c265e4c9e2bcc3bb28
  *>

建议:


厂商补丁:

Samba
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://www.samba.org/samba/security/CVE-2016-2123.html

------------------------------------分割线------------------------------------

如何在Ubuntu 14.04中使用Samba共享文件  http://www.linuxidc.com/Linux/2014-07/104894.htm

VMWare 虚拟机 Ubuntu 双网卡 访问 samba 速度 翻倍 http://www.linuxidc.com/Linux/2013-06/85445.htm

Ubuntu 15.04安装Samba服务 http://www.linuxidc.com/Linux/2016-03/129201.htm

Samba服务器安装和配置  http://www.linuxidc.com/Linux/2014-12/110459.htm

Ubuntu 16.04下Samba相关配置  http://www.linuxidc.com/Linux/2016-12/138498.htm

CentOS部署Samba企业文件共享服务 http://www.linuxidc.com/Linux/2016-06/132609.htm

怎样设置Samba文件服务器以使用Windows客户端  http://www.linuxidc.com/Linux/2014-08/105786.htm

CentOS 6.7下 Samba服务器的搭建与配置(share共享模式)  http://www.linuxidc.com/Linux/2016-12/138220.htm

------------------------------------分割线------------------------------------

Samba 的详细介绍请点这里
Samba 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-01/139787.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款