你好,游客 登录 注册 搜索
背景:
阅读新闻

Google gRPC 堆缓冲区溢出漏洞(CVE-2017-7861)

[日期:2017-04-18] 来源:Linux社区  作者:Linux [字体: ]
Google gRPC 堆缓冲区溢出漏洞(CVE-2017-7861)


发布日期:2017-03-14
更新日期:2017-04-18

受影响系统:

Google gRPC < 2017-02-22

描述:


BUGTRAQ  ID: 97694
CVE(CAN) ID: CVE-2017-7861

gRPC是一个高性能、通用的开源RPC框架。

Google gRPC 2017-02-22之前版本存在堆缓冲区溢出漏洞,此漏洞位于core/lib/support/alloc.c内的gpr_free函数,可导致越界写操作。

<*来源:Monor
  *>

建议:


厂商补丁:

Google
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=655
https://github.com/grpc/grpc/pull/9833

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-04/142890.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款