你好,游客 登录 注册 搜索
背景:
阅读新闻

FreeType 堆缓冲区溢出漏洞(CVE-2017-8287)

[日期:2017-04-27] 来源:Linux公社  作者:Linux [字体: ]
FreeType 堆缓冲区溢出漏洞(CVE-2017-8287)


发布日期:2017-04-21
更新日期:2017-04-27

受影响系统:

FreeType FreeType 2

描述:


CVE(CAN) ID: CVE-2017-8287

FreeType是一个流行的字体函数库。

FreeType 2 < 2017-03-26版本存在堆缓冲区溢出造成的越界写漏洞,此漏洞位于psaux/psobjs.c内的t1_builder_close_contour 函数。

<*来源:vendor
  *>

建议:


厂商补丁:

FreeType
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=941
http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=3774fc08b502c3e685afca098b6e8a195aded6a0

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-04/143218.htm

linux
相关资讯       FreeType 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款