你好,游客 登录 注册 搜索
背景:
阅读新闻

CentOS 7.2安装配置 FreeSwitch X-Lite

[日期:2017-04-28] 来源:Linux社区  作者:lwm666 [字体: ]

CentOS 7.2 编译FreeSwitch

 

  • FreeSwitch版本 : 1.6

  • 操作系统基本是最小安装

  • 时间:2017-04/26

温馨提示 : 如果想更快的编译成功可以先把所有的yum的软件安装完成(及所有的yum命令执行一下)

步骤和问题解决

  • 1.安装git

  • yum install Git

  • 2.获取源码

  • git clone https://freeswitch.org/stash/scm/fs/freeswitch.git freeswitch.git

     3.按照官方文档搭建环境

yum install -y http://files.freeswitch.org/freeswitch-release-1-6.noarch.rpm epel-release11
  • 安装开发环境(上面步骤需要成功)

yum install -y git gcc-c++ autoconf automake libtool wget python ncurses-devel zlib-devel libjpeg-devel openssl-devel e2fsprogs-devel sqlite-devel libcurl-devel pcre-devel speex-devel ldns-devel libedit-devel libxml2-devel libyuv-devel opus-devel libvpx-devel libvpx2* libdb4* libidn-devel unbound-devel libuuid-devel lua-devel libsndfile-devel yasm-devel11

4.开始编译

  • 编译

./bootstrap.sh -j11
  • 注意:执行失败提示( autoconf not found)

yum install autoconf automake libtool11
  • 再次编译

./bootstrap.sh -j ./configure1212

5.解决configure中出现的错误

  • 1 . The C++ compiler does not work. Please (re)install the C++ compiler

yum install gcc-c++11
  • 2 . no usable zlib; please install zlib devel package or equivalent

yum install zlib-devel11
  • 3 . Library requirements (sqlite3 >= 3.6.20) not met;

yum install sqlite-devel11
  • 4 . Library requirements (libcurl >= 7.19) not met;

yum install curl-devel11
  • 5 . Library requirements (libpcre >= 7.8) not met;

yum install pcre-devel11
  • 6 . Library requirements (speex >= 1.2rc1 speexdsp >= 1.2rc1) not met;

yum install speex-devel11
  • 7 . You need to either install libldns-dev or disable mod_enum in modules.conf

yum install ldns-devel11
  • 8 . You need to either install libedit-dev (>= 2.11) or configure with –disable-core-libedit-support

yum install libedit-devel11
  • 9 . OpenSSL >= 1.0.1e and associated developement headers required

yum install openssl-devel11
  • 成功后的结果应该是下图所示

默认情况的configure结果

6 . 解决编译时的错误

  • 编译

make11
  • 6.1 Neither yasm nor nasm have been found.

yum install nasm -y11
  • 6.2 fatal error: lua.h: No such file or directory

yum install lua-devel11
  • 6.3 You must install libopus-dev to build mod_opus. Stop.

yum install opus-devel ./configure && make1212
  • 6.4 You must install libsndfile-dev to build mod_sndfile.

yum install libsndfile-devel ./configure && make1212
  • 编译成功结果

编译成功后的终端显示效果

7 安装到默认目录

  • 安装

make install11
  • 结果 
    安装后的提示 
    提示

  • 安装声音文件 
    这个是需要下载的,可以不用安装

make cd-moh-install && make cd-sounds-install

安装SIP软电话X-lite

注意:需要联网安装

第二步:

最后测试:

CentOS 7.2安装配置 FreeSwitch X-Lite

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-04/143228.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款