你好,游客 登录 注册 搜索
背景:
阅读新闻

PHP zend_string_extend函数拒绝服务漏洞(CVE-2017-8923)

[日期:2017-05-16] 来源:Linux社区  作者:Linux [字体: ]
PHP zend_string_extend函数拒绝服务漏洞(CVE-2017-8923)


发布日期:2017-05-14
更新日期:2017-05-16

受影响系统:

PHP PHP <7.1.5

描述:


CVE(CAN) ID: CVE-2017-8923

PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。

PHP < 7.1.5版本,Zend/zend_string.h/zend_string_extend函数未阻止更改字符串对象,导致出现负长度,可使远程攻击者利用此漏洞执行拒绝服务攻击。

<*来源:vendor
 
  链接:https://bugs.php.net/bug.php?id=74577
*>

建议:


厂商补丁:

PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.php.net/downloads.php

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-05/143835.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款