你好,游客 登录 注册 搜索
背景:
阅读新闻

VideoLAN VLC ParseJSS 信息泄露漏洞(CVE-2017-8312)

[日期:2017-05-25] 来源:Linux社区  作者:Linux [字体: ]
VideoLAN VLC ParseJSS 信息泄露漏洞(CVE-2017-8312)


发布日期:2017-05-18
更新日期:2017-05-25

受影响系统:

VideoLAN VLC Media Player < 2.2.5

描述:


CVE(CAN) ID: CVE-2017-8312

VLC Media Player是多媒体播放器。

VideoLAN VLC < 2.2.5版本,由于未检查字符串长度,ParseJSS中存在堆越界读漏洞,可使攻击者通过构造的副标题文件,可越界读取未初始化堆信息。

<*来源:vendor
  *>

建议:


厂商补丁:

VideoLAN
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://git.videolan.org/?p=vlc.git;a=blobdiff;f=modules/demux/subtitle.c;h=5e4fcdb7f25b2819f5441156c7c0ea2a7d112ca3;hp=2a75fbfb7c3f56b24b2e4498bbb8fe0aa2575974;hb=611398fc8d32f3fe4331f60b220c52ba3557beaa;hpb=075bc7169b05b004fa0250e4a4ce5516b05487a9

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-05/144207.htm

linux
相关资讯       VideoLAN 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款