你好,游客 登录 注册 搜索
背景:
阅读新闻

OpenLDAP 'servers/slapd/back-mdb/search.c' 拒绝服务漏洞(CVE-2017-9287)

[日期:2017-06-01] 来源:Linux社区  作者:Linux [字体: ]
OpenLDAP 'servers/slapd/back-mdb/search.c' 拒绝服务漏洞(CVE-2017-9287)


发布日期:2017-05-30
更新日期:2017-06-01

受影响系统:

OpenLDAP OpenLDAP <= 2.4.44
    - Apple MacOS 9.2.2

描述:


BUGTRAQ  ID: 98736
CVE(CAN) ID: CVE-2017-9287

OpenLDAP是LDAP协议的一个开源实现。

OpenLDAP 2.4.44及之前版本,servers/slapd/back-mdb/search.c中存在双重释放漏洞,具有目录搜索权限的用户若发送构造的搜索请求,可造成slapd崩溃。

<*来源:Ryan Tandy
  *>

建议:


厂商补丁:

OpenLDAP
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://bugs.debian.org/863563
http://www.openldap.org/its/?findid=8655

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-06/144417.htm

linux
相关资讯       OpenLDAP 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款