你好,游客 登录 注册 搜索
背景:
阅读新闻

GnuTLS 栈缓冲区溢出漏洞(CVE-2017-6891)

[日期:2017-06-06] 来源:Linux社区  作者:Linux [字体: ]
GnuTLS 栈缓冲区溢出漏洞(CVE-2017-6891)


发布日期:2017-06-01
更新日期:2017-06-06

受影响系统:

GnuTLS GnuTLS 4.10

描述:


BUGTRAQ  ID: 98641
CVE(CAN) ID: CVE-2017-6891

GnuTLS是SSL、TLS和DTLS的开源实现。

GnuTLS libtasn1 4.10版本,"asn1_find_node()"函数(lib/parser_aux.c)存在错误,攻击者诱使用户处理构造的分配文件,造成栈缓冲区溢出。

<*来源:Jakub Jirasek
  *>

建议:


厂商补丁:

GnuTLS
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://git.savannah.gnu.org/gitweb/?p=libtasn1.git;a=commit;h=5520704d075802df25ce4ffccc010ba1641bd484

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-06/144563.htm

linux
相关资讯       GnuTLS 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款