你好,游客 登录 注册 搜索
背景:
阅读新闻

Apache HTTP Server 缓冲区溢出漏洞(CVE-2017-7668)

[日期:2017-06-20] 来源:Linux社区  作者:Linux [字体: ]
Apache HTTP Server 缓冲区溢出漏洞(CVE-2017-7668)


发布日期:2017-06-12
更新日期:2017-06-20

受影响系统:

Apache Group HTTP Server 2.4.25
Apache Group HTTP Server 2.4.24
Apache Group HTTP Server 2.2.32

描述:


CVE(CAN) ID: CVE-2017-7668

Apache HTTP Server是Apache软件基金会的一个开放源代码的网页服务器。

httpd 2.2.32、2.4.24、2.4.25版本,在令牌列表解析中存在bug,可使ap_find_token()搜索输入字符串之外的内容,通过构造的请求头序列,攻击者可造成段故障,或强制ap_find_token()返回错误值。

<*来源:Javier Jiménez (javijmor@gmail.com)
  *>

建议:


厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://httpd.apache.org/security/vulnerabilities_24.html

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-06/145014.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款