你好,游客 登录 注册 搜索
背景:
阅读新闻

GNU Debugger (GDB) 拒绝服务漏洞(CVE-2017-9778)

[日期:2017-06-26] 来源:Linux社区  作者:Linux [字体: ]
GNU Debugger (GDB) 拒绝服务漏洞(CVE-2017-9778)


发布日期:2017-06-23
更新日期:2017-06-26

受影响系统:

GNU Debugger <= 8.0

描述:


BUGTRAQ  ID: 99244
CVE(CAN) ID: CVE-2017-9778

GNU Debugger (GDB) 是GNU软件系统中的标准侦错器。

GNU Debugger (GDB) 8.0及更早版本,未成功检测到DWARF区的负长度字段,ELF二进制文件或核心文件内畸形段可造成GDB重复分配内存,导致拒绝服务。

<*来源:vendor
  *>

建议:


厂商补丁:

GNU
---
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:

https://sourceware.org/bugzilla/show_bug.cgi?id=21600

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-06/145222.htm

linux
相关资讯       GDB 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款