你好,游客 登录 注册 搜索
背景:
阅读新闻

glibc res_query拒绝服务漏洞(CVE-2015-5180)

[日期:2017-06-28] 来源:Linux社区  作者:Linux [字体: ]
glibc res_query拒绝服务漏洞(CVE-2015-5180)


发布日期:2017-06-23
更新日期:2017-06-28

受影响系统:

GNU glibc < 2.25

描述:


CVE(CAN) ID: CVE-2015-5180

glibc是GNU发布的libc库,即c运行库。

glibc < 2.25版本,libresolv/res_query在实现上存在安全漏洞,可使远程攻击者造成拒绝服务(空指针间接引用及进程崩溃)。

<*来源:Florian Weimer
 
  *>

建议:


厂商补丁:

GNU
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=fc82b0a2dfe7dbd35671c10510a8da1043d746a5
https://sourceware.org/ml/libc-alpha/2017-02/msg00079.html
https://sourceware.org/bugzilla/show_bug.cgi?id=18784
https://sourceware.org/bugzilla/attachment.cgi?id=8492
https://bugzilla.redhat.com/show_bug.cgi?id=1249603
http://www.ubuntu.com/usn/USN-3239-2
http://www.ubuntu.com/usn/USN-3239-1

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-06/145284.htm

linux
相关资讯       glibc漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款