你好,游客 登录 注册 搜索
背景:
阅读新闻

新安装的CodeBlocks无法编译运行问题解决

[日期:2017-07-11] 来源:Linux社区  作者:嘟嘟嘟嘟 [字体: ]

没有用过CodeBlocks这个C/C++IDE,因要做作业,所以下载了,但发现无法编译更加不用说运行了,形况如下图:

这里写图片描述

这种形况是怎么回事呢?

看了下提示,原来是没有编译器!!
发现了自己下载安装的是没有编译器的版本,悲剧的是,我电脑中也没有安装其他的编译器。
有什么方法解决问题呢?

我的解决方案就是卸载了重新安装!

在官网中下载到这步,选择二进制版本,如图:
这里写图片描述

点击进入:
这里写图片描述
框中上面的版本就是没有编译器的版本啦!之前我就是下载了这个版本!!框中的两个版本可以任意选择!我选择的是.zip的。

等待下载完后,编译后又出现原来的问题!!为什么?

我在看了下那提示,原来还是设置问题。我把压缩包解压后的文件换了个文件夹,是导致这次出错的原因,如下图设置回来:

这里写图片描述

点击Auto-detect,路径就更改回来了,点击OK就可以了!这次编译运行就没有问题了!!!

上一张图:
这里写图片描述

Ubuntu 12.04 下安装Code::Block 见 http://www.linuxidc.com/Linux/2012-10/73116.htm

Kubuntu 14.10 下安装Code::Blocks 13.12  http://www.linuxidc.com/Linux/2015-04/116382.htm

Code::Blocks 的详细介绍请点这里
Code::Blocks 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-07/145556.htm

linux
相关资讯       CodeBlocks 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款