你好,游客 登录 注册 搜索
背景:
阅读新闻

augeas 内存破坏漏洞(CVE-2017-7555)

[日期:2017-08-26] 来源:Linux社区  作者:Linux [字体: ]
augeas 内存破坏漏洞(CVE-2017-7555)


发布日期:2017-08-23
更新日期:2017-08-26

受影响系统:

Augeas Augeas <= 1.8.0

描述:


BUGTRAQ  ID: 100378
CVE(CAN) ID: CVE-2017-7555

augeas 是配置编码工具。

Augeas <= 1.8.0 未正确处理转义字符串,在实现上存在堆缓冲区溢出漏洞,可使攻击者通过构造的字符串,可导致应用崩溃或任意代码执行。

<*来源:Han Han (Red Hat)
  *>

建议:


厂商补丁:

Augeas
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/hercules-team/augeas/pull/480

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-08/146517.htm

linux
相关资讯       Augeas 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款