你好,游客 登录 注册 搜索
背景:
阅读新闻

OpenJPEG opj_t2_encode_packet函数堆缓冲区溢出漏洞(CVE-2017-14039)

[日期:2017-08-31] 来源:Linux社区  作者:Linux [字体: ]
OpenJPEG opj_t2_encode_packet函数堆缓冲区溢出漏洞(CVE-2017-14039)


发布日期:2017-08-29
更新日期:2017-08-31

受影响系统:

OpenJPEG OpenJPEG 2.2.0

描述:


CVE(CAN) ID: CVE-2017-14039

OpenJPEG库是用C语言编写的开源JPEG 2000编码解码器。

OpenJPEG 2.2.0版本,lib/openjp2/t2.c/opj_t2_encode_packet函数存在堆缓冲区溢出漏洞,可导致远程拒绝服务。

<*来源:vendor
  *>

建议:


厂商补丁:

OpenJPEG
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://blogs.gentoo.org/ago/2017/08/28/openjpeg-stack-based-buffer-overflow-write-in-pgxtoimage-convert-c/

https://github.com/uclouvain/openjpeg/commit/c535531f03369623b9b833ef41952c62257b507e

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-08/146623.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款