你好,游客 登录 注册 搜索
背景:
阅读新闻

ImageMagick WriteMSLImage内存泄露漏洞(CVE-2017-14139)

[日期:2017-09-06] 来源:Linux社区  作者:Linux [字体: ]
ImageMagick WriteMSLImage内存泄露漏洞(CVE-2017-14139)


发布日期:2017-08-31
更新日期:2017-09-06

受影响系统:

ImageMagick ImageMagick 7.0.6-2

描述:


CVE(CAN) ID: CVE-2017-14139

ImageMagick是一款Unix/Linux平台下开源的图像查看和编辑工具。

ImageMagick 7.0.6-2版本,coders/msl.c/WriteMSLImage中存在内存泄露漏洞,可导致信息泄露。

<*来源:vendor
  *>

建议:


厂商补丁:

ImageMagick
-----------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/ImageMagick/ImageMagick/issues/578

相关阅读

利用ImageMagick绘制三基色原理图 http://www.linuxidc.com/Linux/2012-09/70007.htm

Linux下ImageMagick的安装和使用  http://www.linuxidc.com/Linux/2017-03/141419.htm

Linux下PHP支持ImageMagick和MagicWandForPHP http://www.linuxidc.com/Linux/2011-01/31539.htm

Linux下用ImageMagick玩图像魔术 http://www.linuxidc.com/Linux/2010-06/26921.htm

Linux下ImageMagick和MagicWand For PHP的安装 http://www.linuxidc.com/Linux/2008-07/14525.htm

Linux下ImageMagick和JMagick的安装整理 http://www.linuxidc.com/Linux/2008-09/15649.htm

Ubuntu 16.04下交叉编译ImageMagick  http://www.linuxidc.com/Linux/2017-09/146714.htm

Linux系统上编译好的ImageMagick迁移到另一台机器 http://www.linuxidc.com/Linux/2017-03/141420.htm

ImageMagick 的详细介绍请点这里
ImageMagick 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-09/146767.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款