你好,游客 登录 注册 搜索
背景:
阅读新闻

FFmpeg 'libavformat/asfdec_f.c'拒绝服务漏洞(CVE-2017-14223)

[日期:2017-09-12] 来源:Linux社区  作者:Linux [字体: ]
FFmpeg 'libavformat/asfdec_f.c'拒绝服务漏洞(CVE-2017-14223)


发布日期:2017-09-09
更新日期:2017-09-12

受影响系统:

FFmpeg FFmpeg 3.3.3

描述:


BUGTRAQ  ID: 100703
CVE(CAN) ID: CVE-2017-14223

FFmpeg是一个免费的可以执行音讯和视讯多种格式的录影、转档、串流功能的软件。

FFmpeg 3.3.3版本libavformat/asfdec_f.c中,由于缺少文件结尾检查,asf_build_simple_index()中存在拒绝服务漏洞,可导致耗尽CPU内存资源。

<*来源:Xiaohei
        Wangchu
  *>

建议:


厂商补丁:

FFmpeg
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/FFmpeg/FFmpeg/commit/afc9c683ed9db01edb357bc8c19edad4282b3a97

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-09/146841.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款