你好,游客 登录 注册 搜索
背景:
阅读新闻

Dnsmasq 堆缓冲区溢出漏洞(CVE-2017-14492)

[日期:2017-10-09] 来源:Linux社区  作者:Linux [字体: ]
Dnsmasq 堆缓冲区溢出漏洞(CVE-2017-14492)


发布日期:2017-10-09
更新日期:2017-10-09

受影响系统:

Dnsmasq Dnsmasq < 2.78

描述:


BUGTRAQ  ID: 101085
CVE(CAN) ID: CVE-2017-14492

Dnsmasq是轻型DNS转发器和DHCP服务器。

dnsmasq 2.78之前版本在实现上存在堆缓冲区溢出漏洞,可使远程攻击者通过构造的IPv6路由器广告请求,造成拒绝服务或执行任意代码。

<*来源:Felix Wilhelm
        Fermin J. Serna
        Gabriel Campana
  *>

建议:


厂商补丁:

Dnsmasq
-------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://thekelleys.org.uk/dnsmasq/CHANGELOG

http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=24036ea507862c7b7898b68289c8130f85599c10

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-10/147397.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款