你好,游客 登录 注册 搜索
背景:
阅读新闻

Ubuntu下IPython的搭建和使用

[日期:2017-10-11] 来源:Linux社区  作者:ECJTUACM-873284962 [字体: ]

1. Ubuntu作系统版本

说明:Ubuntu 12.04.3 LTS自带的Python 2.7.3版本。

2. 安装IPython

说明:

输入命令sudo apt-get install ipython,然后输入密码即可。

3. install ipython-qtconsole

上面出现错误的原因是还没有安装matplotlib模块,安装之后,则:

同时,弹出如下窗口:

说明:IPython团队开发了一个基于Qt框架(其目的是为终端应用程序提供诸如内嵌图片、多行编辑、语法高亮之类

的富文本编辑功能)的GUI控制台。Qt控制台可以通过标签页的形式启动多个IPython进程,这就使你能够在多个任务

之间轻松切换。

4. 第三方安装工具--easy_install


说明:

easy_install是由PEAK(Python Enterprise Application Kit)开发的setuptools包里带的一个命令,所以使用easy_install

实际上是在调用setuptools来完成安装模块的工作。

注意:当然还有其它安装工具,不过这里只介绍easy_install一种,因为工具的价值在于创造价值,而不是工具本身。

5. 安装matplotlib模块

如果出现如上错误,则:


然后,安装numpy和matplotlib模块:

6. install ipython notebook

安装之后,然后启动:

启动之后,效果如下:


本文永久更新链接地址http://www.linuxidc.com/Linux/2017-10/147472.htm

linux
相关资讯       IPython 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款