手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Canonical修复Ubuntu 16.04安装Meltdown补丁导致引导失败的问题

[日期:2018-01-11] 来源:Linux公社  作者:鱼鱼 [字体: ]

Canonical周三发布了针对Ubuntu 16.04 LTS(Xenial Xerus)操作系统系列的新Linux内核更新,以解决昨日针对Meltdown漏洞的安全补丁中引起的回退问题。

Canonical周二发布了多个安全通知,通知Ubuntu 17.10,Ubuntu 16.04 LTS,Ubuntu 14.04 LTS和Ubuntu 12.04 ESM操作系统的用户,他们现在可以针对影响数十亿设备的Meltdown安全漏洞修补计算机。

但是,一些运行Ubuntu 16.04 LTS的用户立即报告说,在安装新的内核更新后,他们的系统无法启动。关于这个问题的报道并不多,但是Canonical今天在一个安全公告中证实了这个回退,并且发布了一个更新的内核来解决问题。

“USN-3522-1修复了Linux内核中的一个漏洞,以解决Meltdown(CVE-2017-5754)。不幸的是,该更新引入了一些回退,其中有几个系统无法成功启动。我们对给您带来的不便表示歉意。“Canonical在安全咨询中表示

更新了可用于Ubuntu 14.04 LTS用户的Xenial HWE内核

由于一些用户仍在使用Ubuntu 14.04 LTS(Trusty Tahr)操作系统,Canonical还更新了Ubuntu 14.04.5 LTS系统的Xenial HWE(硬件启用)内核,解决了在安装昨天的Meltdown补丁之后使机器无法启动的相同回退问题。

Canonical建议所有用户立即更新他们的系统。使用Ubuntu 16.04 LTS(Xenial Xerus)的用户应该将他们的内核更新到linux-image 4.4.0.109.114(generic或lowlatency),而使用Ubuntu 14.04.5 LTS和Xenial HWE内核的用户需要更新到linux-image 4.4.0-109.132~14.04.1.。

如果由于昨天的内核更新而导致计算机不再可引导,您仍然可以在引导时通过GRUB引导加载程序屏幕访问之前安装的内核映像,并选择其他内核。当您的机器启动,登录,安装所有可用的更新,然后重新启动。

相关:

所有树莓派设备都不受Meltdown 和 Spectre漏洞影响  http://www.linuxidc.com/Linux/2018-01/150134.htm

完整指南:如何在Windows上修补Metldown 和 Spectre漏洞  http://www.linuxidc.com/Linux/2018-01/150095.htm

SUSE就SLE 与 openSUSE应对Meltdown 和 Spectre CPU漏洞发布声明  http://www.linuxidc.com/Linux/2018-01/150092.htm

Canonical即将发布面向所有Ubuntu版本的Meltdown和Spectre漏洞补丁  http://www.linuxidc.com/Linux/2018-01/150091.htm

Meltdown和Spectre两个严重的硬件错误,数十亿设备面临攻击风险  http://www.linuxidc.com/Linux/2018-01/150079.htm

Red Hat公司表示Meltdown和Spectre漏洞可能会影响性能  http://www.linuxidc.com/Linux/2018-01/150078.htm

Canonical发布Ubuntu Kernel和NVIDIA更新以修复Meltdown与Spectre漏洞  http://www.linuxidc.com/Linux/2018-01/150219.htm

更多Ubuntu相关信息见Ubuntu 专题页面 http://www.linuxidc.com/topicnews.aspx?tid=2

本文永久更新链接地址http://www.linuxidc.com/Linux/2018-01/150226.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款