手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

注意:当前与Ubuntu 20.04绑定的是Microsoft Windows WSL1

[日期:2020-04-12] 来源:Linux公社  作者:醉落红尘 [字体: ]

Linux 的 Windows 子系统的公共服务公告(WSL)当前在运行Ubuntu 20.04 LTS时会出现问题,因此用户应该等待Microsoft发布修复程序,升级到WSL2,或者坚持使用较旧的Ubuntu 18.04 LTS。

注意:当前与Ubuntu 20.04绑定的是Microsoft Windows WSL1

由于操作系统随附Glibc 2.31,Ubuntu 20.04 LTS在WSL(1)上遇到问题。通过更新的GNU C库,使用CLOCK_REALTIME的nanosleep()有了变化。但是Linux的Windows子系统没有内置CLOCK_REALTIME支持,因此现在用户需要等待Windows的Windows子系统将CLOCK_REALTIME支持添加到使用WSL的glibc处理中。

尽管Ubuntu 20.04 LTS将在两周内正式发布,但在Windows Insider版本之外为其提供的WSL1修复程序可能不会在几个月内看到解决该问题的修复程序。

在向大众发布此类修复程序之前,WSL用户应坚持使用Ubuntu 18.04 LTS,否则应切换到使用WSL2。

通过此警告帖子获得更多详细信息。

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2020-04/162878.htm

注意:当前与Ubuntu 20.04绑定的是Microsoft Windows WSL1

linux
相关资讯       WSL  Ubuntu 20.04 LTS  WSL1 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款