手机版
你好,游客 登录 注册
背景:
阅读新闻

TP-Link 703N刷OpenWrt的实践

[日期:2013-05-19] 来源:Linux社区  作者:Linux [字体: ]

1)下载编译好的固件

从OpenWrt的官方站点https://openwrt.org/

http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-wr2543-v1-squashfs-factory.bin

固件分为squashfs和jiffs2两种文件系统。具体的区别是jiffs2将固件本身和后续安装的包会放置在一个分区内,因此可以充分利用空间。squashfs则将固件单独挂在在/rom分区,系统出现问题时,系统的恢复非常便利。推荐squashfs!关键时刻留有退路。

2)通过原有的路由器管理页面,进行固件升级。

注意重启没有完成前,不要关掉页面。

3)初始设置

A) password重置

默认的网段为192.168.1.*。将703N用网线和PC相连,且将PC的IP设置为不为192.168.1.1的任意IP。这里假设为192.168.1.100,掩码为255.255.255.0。通过PC,telnet 192.168.1.1后,若可连接。则大功成半。然后

将root的密码进行重置。因为要用telnet和SSH的缘故,windows上要安装putty和配置自带的telnet,便利起见,推荐直接使用安装linux的PC。

B) SSH到703N(ssh root@192.168.1.1)更改网络配置

默认情况下不开启wifi,另外需要连接到网络来安装软件,所以需要修正配置文件。

这里假设连接到另一路由器,来充当AP。(前提是DCHP的网段不一致,恰巧家里的路由器被我设为192.168.0.*网段了)如果是直接充当路由器,则设置类型需要设置为PPPoE。

-- 修改/etc/config/network文件,将静态IP设置修改为DHCP。

config interface 'lan'

option ifname 'eth0'

option type 'bridge'

option proto 'dhcp'

#option proto 'static'

#option ipaddr '192.168.1.1'

#option netmask '255.255.255.0'

#option ip6assign '60'

-- 修改/etc/config/wireless

将option disable 1 注释掉,开启wifi。

如果需要密码的场合,可如下设置

config wifi-iface

option device 'radio0'

option network 'lan'

option mode 'ap'

option ssid 'OpenWrt'

option encryption 'psk2'

option key '12345678'    #这是wifi的密码

C) 重启之后,就可以搜索到名为OpenWrt的无线网络了。

linux
相关资讯       openwrt   TP-LINK 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款