手机版
你好,游客 登录 注册
背景:
阅读新闻

PHP OpenID XML外部实体注入漏洞(CVE-2013-4701)

[日期:2013-08-23] 来源:Linux社区  作者:Linux [字体: ]

发布日期:2013-08-21
更新日期:2013-08-23

受影响系统:
janrain PHP OpenID 2.x
描述:
--------------------------------------------------------------------------------
BUGTRAQ  ID: 61898
CVE(CAN) ID: CVE-2013-4701

OpenID是PHP5的库。

PHP OpenID 2.2.2在解析XRDS数据内的XML外部实体时出错,可被利用泄露本地资源或耗尽过量服务器资源。

<*来源:Takeshi Terada (Mitsui Bussan Secure Directions, Inc)
 
  链接:http://secunia.com/advisories/54542/
*>

建议:
--------------------------------------------------------------------------------
厂商补丁:

janrain
-------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://janrain.com/openid-enabled/

linux
相关资讯       OpenID 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款