手机版
你好,游客 登录 注册
背景:
阅读新闻

PostgreSQL安全限制绕过漏洞(CVE-2014-0060)

[日期:2014-02-24] 来源:Linux社区  作者:Linux [字体: ]

发布日期:2014-02-17
更新日期:2014-02-24

受影响系统:
PostgreSQL PostgreSQL 8.x
描述:
--------------------------------------------------------------------------------
BUGTRAQ  ID: 65723
CVE(CAN) ID: CVE-2014-0060

PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。

PostgreSQL 9.3.3, 9.2.7, 9.1.12, 9.0.16, 8.4.20之前版本在实现上存在安全漏洞,“GRANT ... WITHOUT ADMIN OPTION”限制可被绕过,攻击者可利用此漏洞获取管理员权限,撤销其他用户的访问权限。

<*来源:Noah Misch
        Jonas Sundman
 
  链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2014-0060
*>

建议:
--------------------------------------------------------------------------------
厂商补丁:

PostgreSQL
----------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.postgresql.org

PostgreSQL 的详细介绍请点这里
PostgreSQL 的下载地址请点这里

PostgreSQL缓存详述 http://www.linuxidc.com/Linux/2013-07/87778.htm

Windows平台编译 PostgreSQL http://www.linuxidc.com/Linux/2013-05/85114.htm

Ubuntu下LAPP(Linux+Apache+PostgreSQL+PHP)环境的配置与安装 http://www.linuxidc.com/Linux/2013-04/83564.htm

Ubuntu上的phppgAdmin安装及配置 http://www.linuxidc.com/Linux/2011-08/40520.htm

linux
相关资讯       PostgreSQL漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款