手机版
你好,游客 登录 注册
背景:
阅读新闻

Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pycharm过程(Simple)

[日期:2017-11-15] 来源:CSDN  作者:YHangbin [字体: ]

写在前面

在配置了多次之后,为了加深印象,进行此次总结。事实表明硬件环境越好配置起来越顺利。第一次配置是在独显是GT610M的笔记本上进行配置,问题非常多。

- 0、对系统进行更新

sudo apt-get update
sudo apt-get upgrade

- 1、安装NVIDIA驱动

方法一(很简洁,但很有用):
直接在Ubuntu系统设置,软件和更新里面,选择中国的服务器源刷新之后,点击附加驱动选项,在Nvidia Corporation选择专有驱动,然后点击应用更改,下载安装完之后重启。
方法二(很麻烦,且很容易出问题):
第一种方法可能会因为显卡太老,导致检查出来的驱动版本不支持CUDA。会在后续出现
CUDA driver version is insufficient for CUDA runtime version 的错误。这时候需要对显卡强制进行更新.
1、去官方下载好驱动的run文件,选择对应显卡型号下载。
2、终端下sudo gedit /etc/modprobe.d/blacklist.conf
3、输入密码,后在最后一行编辑上 blacklist nouveau
4、Ctrl +C保存后终端输入sudo update-initramfs -u
5、重启之后在界面按Ctrl+Alt+F2,输入root以及密码,然后 linux service lightdm stop
6、sh 你自己的驱动文件的完整路径,默认选项就可以安装了,安装后重启
方法三(未实践):
配置过几次环境之后,在后面安装CUDA驱动的时候,也会出现是否安装NVIDIA驱动的选项。但是许多教程都是选择了否。(并且驱动版本很新,完全满足CUDA的要求)因此考虑是否可以跳过安装驱动的步骤,直接安装CUDA时候一起进行安装。待今后有机会再进行实践。
测试
nvidia-smi(注意没空格)会输出支持cuda的GPU设备列表

- 2、安装Cuda

在https://developer.nvidia.com/cuda-downloads,根据自己的系统下载对应的runfile文件。
下载后运行sudo ./cuda_8.0.61_375.26_linux.run --tmpdir=/tmp
1、运行后,首先是协议。按空格到底后,输入accept

Do you accept the previously read EULA?
accept/decline/quit: accept

Install NVIDIA Accelerated Graphics Driver for Linux-x86_64 367.48?
(y)es/(n)o/(q)uit: n

Install the CUDA 8.0 Toolkit?
(y)es/(n)o/(q)uit: y

Enter Toolkit Location
[ default is /usr/local/cuda-8.0 ]:

Do you want to install a symbolic link at /usr/local/cuda?
(y)es/(n)o/(q)uit: y

Install the CUDA 8.0 Samples?
(y)es/(n)o/(q)uit: y

2、声明环境变量,并将其写入到 ~/.bashrc 的尾部

export CUDA_HOME=/usr/local/cuda
export PATH=$PATH:$CUDA_HOME/bin
export LD_LIBRARY_PATH=/usr/local/cuda8.0/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

保存退出,运行source ~/.bashrc 或者source /etc/profile

3、添加lib库路径
在 /etc/ld.so.conf.d中加入

#include /usr/local/cuda-8.0/lib64

然后执行

sudo ldconfig #立即生效(source /etc/profile)

4、测试
测试前可以先把samples备份下

cd /usr/local/cuda/samples/1_Utilities/deviceQuery 
sudo make
./deviceQuery

测试结果如下即可
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar

- 3、安装Cudnn

官网下载cudnn-8.0-linux-x64-v5.1.tgz下载后进行解压
解压后把相应的文件拷贝到对应的CUDA目录下即可

sudo cp cuda/include/cudnn.h /usr/local/cuda/include/
sudo cp cuda/lib64/libcudnn* /usr/local/cuda/lib64/
sudo chmod a+r /usr/local/cuda/include/cudnn.h
sudo chmod a+r /usr/local/cuda/lib64/libcudnn*

- 4、安装Caffe

caffe的安装步骤比较繁琐,需要Opencv等软件,所需依赖库比较多。本着宁多勿少的原则,我们首先进行依赖库的安装。
sudo apt-get install libprotobuf-dev libleveldb-dev libsnappy-dev libopencv-dev libhdf5-serial-dev protobuf-compiler 
sudo apt-get install --no-install-recommends libboost-all-dev
sudo apt-get install libopenblas-dev liblapack-dev libatlas-base-dev
sudo apt-get install libgflags-dev libgoogle-glog-dev liblmdb-dev
sudo apt-get install freeglut3-dev build-essential libx11-dev libxmu-dev libxi-dev libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev

主要分为 个步骤:
1、安装Python
可以选择使用系统自带的Python2.7
2、安装Opencv
从官网(http://opencv.org/downloads.html)下载Opencv
解压到要安装的位置,假设解压的地址是/home/opencv
执行命令: `
cd ~/opencv
mkdir build
cd build
配置编译文件:cmake -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX=/usr/local ..

在编译中可能会出现 ippicv 下载不成功的问题,可以通过手动配置来解决这类问题,当然也可以直接配置之后再编译。在进行配置之前,首先前往GitHub下载相应的库https://github.com/opencv/opencv_3rdparty/branches/all 下载后,拷贝到

opencv-x.x.x/3rdparty/ippicv/downloads/linux-808b791a6eac9ed78d32a7666804320e

目录下,然后再运行编译。

编译成功后,运行sudo make install进行安装

安装时候会出现错误:‘NppiGraphcutState’ has not been declared

这是因为opecv3.0与cuda8.0不兼容。 修改~/opencv/modules/cudalegacy/src/graphcuts.cpp文件
在文件开头位置:

把#if !defined (HAVE_CUDA) || defined (CUDA_DISABLER)
修改为
#if !defined (HAVE_CUDA) || defined (CUDA_DISABLER) || (CUDART_VERSION>=8000)

3、测试Opencv
a. 创建工作目录

mkdir ~/opencv-lena
cd ~/opencv-lena
gedit DisplayImage.cpp

b.编辑代码

#include <stdio.h>
#include <opencv2/opencv.hpp>
using namespace cv;
int main(int argc, char** argv )
{
    if ( argc != 2 )
    {
        printf("usage: DisplayImage.out <Image_Path>\n");
        return -1;
    }
    Mat image;
    image = imread( argv[1], 1 );
    if ( !image.data )
    {
        printf("No image data \n");
        return -1;
    }
    namedWindow("Display Image", WINDOW_AUTOSIZE );
    imshow("Display Image", image);
    waitKey(0);
    return 0;
}

c.创建CMake编译文件

gedit CMakeLists.txt

写入内容

cmake_minimum_required(VERSION 2.8)
project( DisplayImage )
find_package( OpenCV REQUIRED )
add_executable( DisplayImage DisplayImage.cpp )
target_link_libraries( DisplayImage ${OpenCV_LIBS} )

d.编译

cd ~/opencv-lena
cmake .
make

e.执行
此时opencv-lena文件夹中已经产生了可执行文件DisplayImage,下载lena.jpg放在opencv-lena下,运行

./DisplayImage lena.jpg

4、安装Matlab
如果在Matlab中使用的话,需要安装Matlab,需要在后续中进行Matlab接口的编译。需要记住自己的安装路径,在后面配置接口的时候要用到。如果不用Matlab 的话就不用安装了。

5、Caffe安装
其实配置没什么技术含量,只是依赖库比较多。需要配置的地方比较多,配置一定要耐心。
1、从https://github.com/BVLC/caffe.git下载caffe到本地
2、解压后,在caffe-master中复制配置文件sudo cp Makefile.config.example Makefile.config
3、修改配置文件sudo gedit Makefile.config根据个人情况进行修改

a.若使用cudnn,则将
#USE_CUDNN := 1
修改成: 
USE_CUDNN := 1

b.若使用的opencv版本是3的,则将
#OPENCV_VERSION := 3 
修改为: 
OPENCV_VERSION := 3

c.若要使用python来编写layer,则将
#WITH_PYTHON_LAYER := 1 
修改为 
WITH_PYTHON_LAYER := 1

d.重要的一项 :
将# Whatever else you find you need goes here.下面的
INCLUDE_DIRS := $(PYTHON_INCLUDE) /usr/local/include
LIBRARY_DIRS := $(PYTHON_LIB) /usr/local/lib /usr/lib 
修改为: 
INCLUDE_DIRS := $(PYTHON_INCLUDE) /usr/local/include /usr/include/hdf5/serial
LIBRARY_DIRS := $(PYTHON_LIB) /usr/local/lib /usr/lib /usr/lib/x86_64-linux-gnu /usr/lib/x86_64-linux-gnu/hdf5/serial     
这是因为ubuntu16.04的文件包含位置发生了变化,尤其是需要用到的hdf5的位置,所以需要更改这一路径.

e.还要更改
USE_OPENCV: = 1
USE_LEVELDB: = 1
USE_LMDB: = 1

4、修改makefile文件

打开makefile文件,将:
NVCCFLAGS +=-ccbin=$(CXX) -Xcompiler-fPIC $(COMMON_FLAGS)
替换为:
NVCCFLAGS += -D_FORCE_INLINES -ccbin=$(CXX) -Xcompiler -fPIC $(COMMON_FLAGS)

5、修改 host_config.h文件

/usr/local/cuda/include/host_config.h
将其中的第115行注释掉:
#error-- unsupported GNU version! gcc versions later than 4.9 are not supported!
改为
//#error-- unsupported GNU version! gcc versions later than 4.9 are not supported!

6、编译

make all -j8 #-j根据自己电脑配置决定

a:可能错误”libcudart.so.8.0 cannot open shared object file: No such file or directory”

a.错误"libcudart.so.8.0 cannot open shared object file: No such file or directory"
解决办法是将一些文件复制到/usr/local/lib文件夹下:(#注意自己CUDA的版本号!)
sudo cp /usr/local/cuda-8.0/lib64/libcudart.so.8.0 /usr/local/lib/libcudart.so.8.0 && sudo ldconfig
sudo cp /usr/local/cuda-8.0/lib64/libcublas.so.8.0 /usr/local/lib/libcublas.so.8.0 && sudo ldconfig
sudo cp /usr/local/cuda-8.0/lib64/libcurand.so.8.0 /usr/local/lib/libcurand.so.8.0 && sudo ldconfig

输出显示如下CXX,无错误提示说明编译通过。
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar

8、测试

a.运行sudo make test 输出显示若干CXX,LD如下即可
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar

b.运行sudo make runtest 输出的所有的RUN均为OK即可确认caffe安装成功 
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar
9、配置pycaffe接口

测试全部成功之后再进行pycaffe接口的配置
a.打开配置文件bashrc

sudo gedit ~/.bashrc

b.在最后面加入caffe目录下的python路径

export PYTHONPATH=/home/yhangbin/caffe-master/python #添加自己的python路径
source ~/.bashrc  #使配置生效

c.配置接口 sudo make pycaffe
显示如下表明借口配置成功
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar

10、配置caffe的Matlab接口

a.修改caffe-master/Makefile.config.主要是要包含bin文件夹
这里写图片描述
b.编译接口sudo make matcaffe
c.测试matlab接口 sudo make mattest
测试结果输出如下所示: 
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar
d.测试python接口 sudo make pytest
 输出如下即可
 Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar    

11、测试Caffe

使用 MNIST数据集 进行测试
a.终端定位到Caffe根目录 cd ~/caffe
b.下载MNIST数据库并解压缩sudo sh ./data/mnist/get_mnist.sh
c.将其转换成Lmdb数据库格式 sudo sh ./examples/mnist/create_mnist.sh

注意:
下载数据库以及转换数据库格式。
解压得到两个文件夹mnist-train-leveldbmnist-test-leveldb复制到 .\examples\mnist\ 目录下即可

在训练网络时可能会出现OSError: libcudnn.so.7.0: cannot open shared object file: No such file or directory错误
因为cuda的路径可能设置错了使用sudo ldconfig /usr/local/cuda/lib64
或者手动添加lib库自动搜索路径到/etc/ld.so.conf
比如:

include /etc/ld.so.conf.d/*.conf
include /usr/local/lib
include .
sudo ldconfig #使配置生效
source /etc/profile

运行sudo sh ./examples/mnist/train_lenet.sh测试效果如下
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar

- 5、安装TensorFlow

TensorFlow的安装还是比较简单的。
1、下载对应版本的TensorFlow
2、执行安装 sudo pip install tensorflow_gpu-0.12.0rc1-cp35-cp35m-linux_x86_64.whl
3、在python中输入import tensorflow as tf测试
这里写图片描述
上面输出的带W的警告,是因为没有通过源代码编译TF,CPU的参数没有开启,因此CPU不支持一系列协议。不过,这只会影响CPU的计算速度,并不影响GPU的计算。
如果是在终端下运行,不显示这个警告。
Ubuntu 16.04下安装CUDA8.0+Caffe+TensorFlow-GPU+Pychar

- 6、在Pycharm中进行配置

1、Caffe配置成功后,在Pycharm中出现ImportError

Pycharm中TensorFlow可以直接import导入。但是在import caffe的时候会出现ImportError: No module named caffe的情况。可以通过手动添加库解决。
a.依次打开File>Setting>Project Interpreter.打开右上角的小齿轮。选择第三个选项 more...
这里写图片描述
b.选择选择最右侧边框上最后一个图标
这里写图片描述
c.点击右侧加号,增加路径
这里写图片描述
d.添加自己的Caffe下的Python路径
这里写图片描述
e.这样便可以成功导入Caffe测试效果如下
这里写图片描述

2、如果还有cannot libcudart 的错误

error:如果caffe还不能正常import 出现 cannot libcudart 的错误,那么用如下方法解决。

a.进入pycharm-community-2016.2/bin
b.使用sudo gedit pycharm.sh 打开pycharm.sh文件
c.

#找到这行
LD_LIBRARY_PATH="$IDE_BIN_HOME:$LD_LIBRARY_PATH" "$Java_BIN" \

 

#添加环境变量
LD_LIBRARY_PATH='/usr/local/cuda/lib64'

# 修改后为
LD_LIBRARY_PATH='/usr/local/cuda/lib64' LD_LIBRARY_PATH="$IDE_BIN_HOME:$LD_LIBRARY_PATH" "$JAVA_BIN" \

d.重新启动pycharm,之前报错的脚本就能正常运行了
最后效果如下所示

这里写图片描述

Attention:有的命令加上sudo反而会出现错误,遇到错误的时候,可以尝试去掉sudo试一下。

Ubuntu 15.04 下Caffe + + CUDA 7.0 安装配置指南  http://www.linuxidc.com/Linux/2016-11/137497.htm

Caffe 深度学习入门教程  http://www.linuxidc.com/Linux/2016-11/136774.htm

Ubuntu 16.04下Matlab2014a+Anaconda2+OpenCV3.1+Caffe安装 http://www.linuxidc.com/Linux/2016-07/132860.htm

Ubuntu 16.04系统下CUDA7.5配置Caffe教程 http://www.linuxidc.com/Linux/2016-07/132859.htm

Caffe在Ubuntu 14.04 64bit 下的安装 http://www.linuxidc.com/Linux/2015-07/120449.htm

深度学习框架Caffe在Ubuntu下编译安装  http://www.linuxidc.com/Linux/2016-07/133225.htm

Caffe + Ubuntu 14.04 64bit + CUDA 6.5 配置说明  http://www.linuxidc.com/Linux/2015-04/116444.htm

Ubuntu 16.04上安装Caffe http://www.linuxidc.com/Linux/2016-08/134585.htm

Caffe配置简明教程 ( Ubuntu 14.04 / CUDA 7.5 / cuDNN 5.1 / OpenCV 3.1 )  http://www.linuxidc.com/Linux/2016-09/135016.htm

Ubuntu 16.04安装 Caffe GPU版  http://www.linuxidc.com/Linux/2017-09/147111.htm

Ubuntu 16.04上安装Caffe(CPU only)  http://www.linuxidc.com/Linux/2016-09/135034.htm

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-11/148629.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款