手机版
你好,游客 登录 注册
背景:
阅读新闻

Squid ESI任意代码执行漏洞(CVE-2016-4054)

[日期:2016-04-26] 来源:Linux社区  作者:Linux [字体: ]
Squid ESI任意代码执行漏洞(CVE-2016-4054)


发布日期:2016-04-21
更新日期:2016-04-26

受影响系统:

Squid Squid 4.x < 4.0.9
Squid Squid 3.x < 3.5.17

描述:


CVE(CAN) ID: CVE-2016-4054

Squid是一个高效的Web缓存及代理程序。

Squid 3.x < 3.5.17、4.x < 4.0.9存在缓冲区溢出漏洞,通过构造的ESI响应,远程攻击者可执行任意代码。

<*来源:CESG
  *>

建议:


厂商补丁:

Squid
-----
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.squid-cache.org/Advisories/SQUID-2016_6.txt

配置Squid代理http和rsync http://www.linuxidc.com/Linux/2013-05/84642.htm

Squid:实现高速的Web访问 http://www.linuxidc.com/Linux/2013-04/83512.htm

CentOS 6.2 编译安装Squid 配置反向代理服务器 http://www.linuxidc.com/Linux/2012-11/74529.htm

简单配置Squid代理和反向代理 http://www.linuxidc.com/Linux/2014-04/99465.htm

CentOS 6.4下DNS+Squid+Nginx+MySQL搭建高可用Web服务器 http://www.linuxidc.com/Linux/2014-04/99984.htm

Squid 的详细介绍请点这里
Squid 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2016-04/130688.htm

linux
相关资讯       Squid漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款