手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

PHP ext/standard/var.c拒绝服务漏洞(CVE-2016-9936)

[日期:2017-01-05] 来源:Linux社区  作者:Linux [字体: ]
PHP ext/standard/var.c拒绝服务漏洞(CVE-2016-9936)


发布日期:2017-01-04
更新日期:2017-01-05

受影响系统:

PHP PHP 7.x < 7.0.14

描述:


CVE(CAN) ID: CVE-2016-9936

PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。

PHP 7.x < 7.0.14版本,ext/standard/var.c反序列化实现中存在安全漏洞,远程攻击者通过构造的序列化数据,可造成拒绝服务。

<*来源:vendor
  *>

建议:


厂商补丁:

PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://bugs.php.net/bug.php?id=72978
https://github.com/php/php-src/commit/b2af4e8868726a040234de113436c6e4f6372d17
http://www.php.net/ChangeLog-7.php

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-01/139231.htm

linux
相关资讯       PHP 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款