手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Spring Boot在JDK1.6下运行Web项目

[日期:2017-03-07] 来源:Linux社区  作者:某某凡人 [字体: ]

报错:Exception in thread "main" Java.lang.UnsupportedClassVersionError: com/saifiahmada/spring/Application : Unsupported major.minor version 51.0

51表示major.minor只能在jdk1.7下才能跑起来。

需要注意是有:

1、jdk1.6的话只支持tomcat7,所以,需要在pom中单独指定7版tomcat以及1.6的jdk:

<properties>
    <tomcat.version>7.0.59</tomcat.version>
</properties>

demo pom:

<properties>
    <webjars-bootstrap.version>3.2.0</webjars-bootstrap.version>
    <webjars-jquery-ui.version>1.9.2</webjars-jquery-ui.version>
    <webjars-jquery.version>2.1.1</webjars-jquery.version>
    <java.version>1.6</java.version>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
    <maven.compiler.source>${java.version}</maven.compiler.source>
    <maven.compiler.target>${java.version}</maven.compiler.target>
    <tomcat.version>7.0.59</tomcat.version>
</properties>

在给一个构建的demo:

<build>
    <plugins>
        <plugin>
            <groupId>org.springframework.boot</groupId>
            <artifactId>spring-boot-maven-plugin</artifactId>
            <!-- <configuration>
                <source>1.6</source>
                <target>1.6</target>
            </configuration> -->
            <dependencies>
                <dependency>
                    <groupId>org.springframework</groupId>
                    <artifactId>springloaded</artifactId>
                    <version>1.2.0.RELEASE</version>
                </dependency>
            </dependencies>
        </plugin>
    </plugins>
</build>

Ps:

spring-boot 1.3的系统要求

 默认情况下,Spring Boot 1.3.0.BUILD-SNAPSHOT 需要Java7和Spring框架4.1.3或以上。你可以在Java6下使用Spring Boot,不过需要添加额外配置。具体参考Section 73.9, “How to use Java 6” 。构建环境明确支持的有Maven(3.2+)和Gradle(1.12+)。

Servlet容器 下列内嵌容器支持开箱即用(out of the box):

 名称          Servlet版本  Java版本
Tomcat 8          3.1        Java 7+
 Tomcat 7          3.0        Java 6+
 Jetty 9                3.1        Java 7+
 Jetty 8                3.0        Java 6+
 Undertow1.1    3.1        Java 7+

你也可以将Spring Boot应用部署到任何兼容Servlet 3.0+的容器。

参考资料:

1、spring-boot compile use jdk 1.7 but run use 1.6:http://stackoverflow.com/questions/28983247/spring-boot-compile-use-jdk-1-7-but-run-use-1-6

2、64.15 Use Tomcat 7:http://docs.spring.io/spring-boot/docs/1.2.2.RELEASE/reference/htmlsingle/

Spring Boot入门学习笔记 http://www.linuxidc.com/Linux/2016-10/135889.htm

Spring Boot+Nginx+Tomcat+SSL配置笔记  http://www.linuxidc.com/Linux/2016-01/127134.htm

Spring Boot 实践心得笔记  http://www.linuxidc.com/Linux/2017-01/139576.htm

Spring Boot的启动器Starter详解 http://www.linuxidc.com/Linux/2016-10/136430.htm

Spring Boot在整合项目依赖jdk反复变成1.5版本的问题  http://www.linuxidc.com/Linux/2017-03/141485.htm

Spring Boot项目搭建入门教程  http://www.linuxidc.com/Linux/2017-01/139901.htm

Spring Boot 的详细介绍请点这里
Spring Boot 的下载地址请点这里

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-03/141488.htm

linux
相关资讯       Spring Boot 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款