手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Grsecurity 被指违反了 GPL 许可证

[日期:2017-07-10] 来源:solidot.org  作者:Linux [字体: ]

开源促进会的联合创始人 Bruce Perens(另一位是 ESR)谈论了内核加固补丁集项目 Grsecurity,认为该项目违反了 Linux 内核采用的 GPL 许可证。在这之前,Linux 创始人 Linus Torvalds 曾在邮件列表上抨击 Grsecurity 的补丁是垃圾。他认为 Grsecurity 是 Linux 的一个衍生作品,它离不开内核,没有内核它无法工作。这意味着 Grsecurity 也必须采用 GPLv2 许可证或兼容 GPLv2 的许可证。而 Grsecurity 目前是一款商业产品,只提供给商业用户,如果商业用户再分发 Grsecurity 的补丁,他们会受到警告,面临惩罚,无法再访问 Grsecurity 的后续补丁。GPLv2 第六节禁止了此类的再分发政策和额外的条款。他建议企业应该避免使用 Grsecurity产品,因为该产品存在违反许可证和违约的风险。

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-07/145529.htm

linux
相关资讯       Grsecurity 
本文评论   查看全部评论 (1)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款
第 1 楼
* 匿名 发表于 2017/7/23 0:01:33
谁说GPLv2必须免费提供源码,GPLv2允许付费后再提供源码的模式,Grsecurity目前正是如此。