你好,游客 登录 注册 搜索
背景:
阅读新闻

Apache Portable Runtime Utility 拒绝服务漏洞(CVE-2017-12618)

[日期:2017-10-25] 来源:Linux社区  作者:Linux [字体: ]
Apache Portable Runtime Utility 拒绝服务漏洞(CVE-2017-12618)


发布日期:2017-10-23
更新日期:2017-10-25

受影响系统:

Apache Group APR <= 1.6.0

描述:


CVE(CAN) ID: CVE-2017-12618

APR-util主要为上层的应用程序提供一个可以跨越多操作系统平台使用的底层支持接口库。

APR-util 1.6.0及之前版本未验证apr_sdbm*()函数使用的SDBM数据库文件的完整性,导致越界读访问,本地用户利用此漏洞可造成崩溃,导致拒绝服务。

<*来源:vendor
  *>

建议:


厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://mail-archives.apache.org/mod_mbox/apr-dev/201710.mbox/%3CCACsi252POs4toeJJciwg09_eu2cO3XFg%3DUqsPjXsfjDoeC3-UQ%40mail.gmail.com%3E

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-10/147953.htm

linux
相关资讯       APR-Util 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款