你好,游客 登录 注册 搜索
背景:
阅读新闻

Apache CXF 拒绝服务漏洞(CVE-2017-11876)

[日期:2017-11-16] 来源:Linux社区  作者:Linux [字体: ]
Apache CXF 拒绝服务漏洞(CVE-2017-11876)


发布日期:2017-11-15
更新日期:2017-11-16

受影响系统:

Apache Group CXF < 3.2.1
Apache Group CXF < 3.1.14

描述:


CVE(CAN) ID: CVE-2017-11876

Apache CXF是一个开源服务框架,用于使用JAX-WS、JAX-RS等前端编程API编译和开发服务。

Apache CXF < 3.2.1、< 3.1.14版本支持通过JAX-WS、JAX-RS来收发附件,但攻击者通过构造消息附件标头,可导致拒绝服务。JAX-WS、JAX-RS均受到此漏洞影响。

<*来源:Wang Shixiang (Kevin)
  *>

建议:


厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/apache/cxf/commit/8bd915bfd7735c248ad660059c6b6ad26cdbcdf6

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-11/148655.htm

linux
相关资讯       Apache CXF  Apache CXF漏洞 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款