你好,游客 登录 注册 搜索
背景:
阅读新闻

libbpg 'cudata.cpp'空指针间接引用拒绝服务漏洞(CVE-2017-13135)

[日期:2017-11-24] 来源:Linux社区  作者:Linux [字体: ]
libbpg 'cudata.cpp'空指针间接引用拒绝服务漏洞(CVE-2017-13135)


发布日期:2017-11-15
更新日期:2017-11-24

受影响系统:

libbpg libbpg 0.9.7

描述:


BUGTRAQ  ID: 101929
CVE(CAN) ID: CVE-2017-13135

libbpg是一种图片格式。

libbpg 0.9.7版本及其他产品中, VideoLAN x265中存在空指针间接引用漏洞,此漏洞源于common/cudata.cpp/CUData::initialize 函数未正确处理内存分配失败,攻击者利用此漏洞可造成受影响应用崩溃。

<*来源:binsh fpbibi
  *>

建议:


厂商补丁:

libbpg
------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://github.com/ebel34/bpg-web-encoder/issues/1

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-11/148843.htm

linux
相关资讯       libbpg 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款