手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

OpenLDAP 'contrib/slapd-modules/nops/nops.c'拒绝服务漏洞

[日期:2017-12-22] 来源:Linux社区  作者:Linux [字体: ]
OpenLDAP 'contrib/slapd-modules/nops/nops.c'拒绝服务漏洞


发布日期:2017-12-19
更新日期:2017-12-22

受影响系统:

OpenLDAP OpenLDAP <= 2.4.45

描述:


BUGTRAQ  ID: 102236
CVE(CAN) ID: CVE-2017-17740

OpenLDAP是LDAP协议的一个开源实现。

OpenLDAP 2.4.45及之前版本,启用了nops模块及memberof overlay后,contrib/slapd-modules/nops/nops.c在实现上存在栈缓冲区溢出漏洞,可使远程攻击者通过成员MODDN操作,造成拒绝服务。

<*来源:Z. Liu
  *>

建议:


厂商补丁:

OpenLDAP
--------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://bugzilla.redhat.com/show_bug.cgi?id=1527076
https://access.redhat.com/security/cve/CVE-2017-17740
http://www.openldap.org/its/index.cgi/Incoming?id=8759
http://www.openldap.org/

本文永久更新链接地址http://www.linuxidc.com/Linux/2017-12/149707.htm

linux
相关资讯       OpenLDAP 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款