手机版
你好,游客 登录 注册
背景:
阅读新闻

运行Linux 4.15内核的系统不会受到Meltdown补丁的影响

[日期:2018-02-01] 来源:Linux公社  作者:鱼鱼 [字体: ]

Linux Kernel

着名的Linux内核维护者Greg Kroah-Hartman今天分享了关于Meltdown和Spectre补丁对Linux内核性能影响的一些有趣的细节。

根据一些用户在某些Linux系统上运行新版内核版本的最新基准测试结果,最近发布的Linux 4.15内核似乎比Linux kernel 4.11快7%到9%。

但是,如果在Linux 4.15内核上启用缓解最近发现的Meltdown安全漏洞的新KPTI(内核页面 - 表隔离)修补程序,则性能仅比运行Linux kernel 4.11的系统慢1到2个百分点。

格雷格·克罗亚 - 哈特曼(Greg Kroah-Hartman)在Google+上表示:“总的来说,我们刚刚回到起点,这让我感觉很好,最近的Meltdown变化并没有成为一个大问题。 但是如果你被困在一个旧的内核版本中,那是完全不同的情况。”

这应该会让所有那些在过去几个月中努力工作的开发人员重新设计Linux内核,以应对Meltdown和Spectre安全漏洞,因为有大量报告指出这些补丁在Linux系统上的巨大影响。

Greg Kroah-Hartman说,更新到一个新的内核版本

Greg Kroah-Hartman建议所有使用Linux内核的GNU/Linux发行版的所有人,如果都使用一个更老的,但长期支持的分支,比如Linux 3.10, 4.4,或4.9,尽快升级到一个新的内核版本,因为现在可能会提高性能。

最新的内核是Linux 4.15,它在周末发布了许多性能改进和一些新特性。如果您的GNU/Linux发行版没有最新的Linux内核,那么您可以自己下载/编译它。

Linux Kernel 4.15正式发布,包括Meltdown和Spectre修补程序 http://www.linuxidc.com/Linux/2018-01/150632.htm

本文永久更新链接地址http://www.linuxidc.com/Linux/2018-02/150698.htm

linux
相关资讯       Meltdown  Meltdown补丁 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款