手机版
你好,游客 登录 注册
背景:
阅读新闻

GNU Binutils远程拒绝服务漏洞(CVE-2018-10534)

[日期:2018-05-05] 来源:Linux社区  作者:Linux [字体: ]
GNU Binutils远程拒绝服务漏洞(CVE-2018-10534)


发布日期:2018-04-28
更新日期:2018-05-05

受影响系统:

GNU Binutils 2.30

描述:


BUGTRAQ  ID: 104025
CVE(CAN) ID: CVE-2018-10534

GNU Binutils是一组编程语言工具程序,它主要用于处理多种格式的目标文件,并提供有连接器、汇编器和其他用于目标文件和档案的工具。Binary File Descriptor(BFD)library(又名libbfd)是其中的一个以各种格式便携式操作对象文件的库。

GNU Binutils 2.30版本,BFD库peXXigen.c文件的‘_bfd_XX_bfd_copy_private_bfd_data_common’函数存在安全漏洞。攻击者可利用该漏洞造成拒绝服务(越边界内存写入)。

<*来源:vendor
  *>

建议:


厂商补丁:

GNU
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

https://sourceware.org/bugzilla/show_bug.cgi?id=23110

本文永久更新链接地址https://www.linuxidc.com/Linux/2018-05/152224.htm

linux
相关资讯       GNU Binutils 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款