手机版
你好,游客 登录 注册 搜索
背景:
阅读新闻

Canonical释出针对Ubuntu 17.10,16.04 LTS和14.04 LTS的内核安全更新

[日期:2018-05-10] 来源:Linux公社  作者:聆听世界的鱼 [字体: ]

Canonical为Ubuntu 17.10(Artful Aardvark),Ubuntu 16.04 LTS(Xenial Xerus)和Ubuntu 14.04 LTS(Trusty Tahr)操作系统系列发布了新的内核安全更新,以解决由各种安全研究人员发现的三个安全漏洞。

Debian项目最近发布了一个针对Debian GNU/Linux 9 “Stretch”和Debian GNU / Linux 8 “Jessie”操作系统系列的类似内核安全补丁,以解决两个安全漏洞,Canonical还发布了内核更新以修补Ubuntu 17.10,Ubuntu 16.04 LTS和Ubuntu 14.04 LTS中的这两个漏洞和另一个漏洞。

其中一个安全漏洞是由Linux内核通过Mov SS或Pop SS指令处理调试异常的方式造成的,这可能会导致本地攻击者通过拒绝服务导致系统崩溃。该问题(CVE-2018-8897)由Nick Peterson发现,仅影响amd64架构。

另一个安全漏洞(CVE-2018-1087)是由Linux内核的KVM(基于内核的虚拟机)子系统引起的,该子系统在通过Mov SS或Pop SS指令进行堆栈切换操作后错误地模拟ICEBP指令,允许非特权用户KVM虚拟机在虚拟机内升级其权限。这个问题是由Andy Lutomirski发现的,并影响到i386和amd64架构。

“这些CVE都与linux内核处理特定中断和异常指令的方式有关,如果中断或异常指令(INT3,SYSCALL等)紧接在MOV SS或POP SS指令之前,则会产生中断被错误地处理,可能会导致操作系统崩溃,“Canonical在一份安全公告中说。

Andy Lutomirski还发现,在这个新的Ubuntu内核安全更新中修补的第三个安全漏洞(CVE-2018-1000199)影响了Linux内核在虚拟化调试寄存器上执行错误处理的方式,这可能允许本地攻击者执行任意代码或者通过造成拒绝服务来使易受攻击的系统崩溃。

敦促用户立即更新他们的系统

今天的内核安全更新可用于i386和amd64体系结构,Raspberry Pi 2系统,亚马逊网络服务(AWS)系统,Microsoft Azure云系统,Intel Euclid系统,Google的Ubuntu 17.10,Ubuntu 16.04 LTS和Ubuntu 14.04 LTS系统云平台(GCP)系统以及Snapdragon处理器,OEM处理器和云环境。

Ubuntu 12.04 ESM客户也可以使用包含相同更改的更新内核。 Canonical敦促所有用户将他们的安装更新到各自Ubuntu版本的稳定软件存储库中现在可用的新内核版本。内核实时修补程序目前无法解决这些问题,因此您必须升级到更正的内核,然后重新启动计算机。

更多Ubuntu相关信息见Ubuntu 专题页面 https://www.linuxidc.com/topicnews.aspx?tid=2

本文永久更新链接地址https://www.linuxidc.com/Linux/2018-05/152307.htm

linux
相关资讯       Ubuntu内核安全更新 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款