手机版
你好,游客 登录 注册
背景:
阅读新闻

Linux 4.19.8与BLK-MQ一起发布,修复EXT4数据损坏Bug

[日期:2018-12-09] 来源:Linux公社  作者:醉落红尘 [字体: ]

希望这个周末您能抽出一些时间来升级到Linux 4.19.8,因为针对最近困扰许多Linux 4.19用户的“EXT4损坏问题”有一个BLK-MQ修复。

Linux 4.19的 ext4 文件系统长期存在一个数据损坏的 BUG。目前已经在 4.20 内核里面被修复 。补丁已经 backport 到 Linux 4.19.8,该 BUG 只在使用 BLK-MQ 并且没有使用 IO 调度器的时候才重现。 

Linux 4.19.8

Linux 4.19.8 截图

Greg Kroah-Hartman刚刚发布了一些稳定的内核点版本。Linux 4.19.8只有一些小的增加,比如支持ELAN0621触摸板,为了更好的支持而调整所有的PDP Xbox One游戏手柄,还有一些小的修正……如果不是因为Jens Axboe的BLK-MQ补丁,Linux 4.19.8的发布就显示没有意义了。

本周早些时候,Linux 4.19+数据损坏问题得到了解决,结果不是EXT4问题,而是多队列块I/O队列机制的问题,在没有I/O调度器的情况下运行时,该机制可能导致一些数据损坏。一旦解决了这个问题,Linux 4.20内核很快就修复了这个问题,现在它已经被向后移植到了4.19.8版本。因此,特别是在使用带有“none”的mq作为I/O调度器选择时,请确保升级到最新版本以确保数据安全。

Greg还发布了Linux 4.14.87和4.9.144作为这些LTS内核的最新版本,尽管没有进行重大更改。

面向Ubuntu 64位的Linux 4.19.8 deb安装包:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19.8/linux-headers-4.19.8-041908_4.19.8-041908.201812080831_all.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19.8/linux-headers-4.19.8-041908-generic_4.19.8-041908.201812080831_amd64.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19.8/linux-image-unsigned-4.19.8-041908-generic_4.19.8-041908.201812080831_amd64.deb
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19.8/linux-modules-4.19.8-041908-generic_4.19.8-041908.201812080831_amd64.deb

如何在Ubuntu 18.04/18.10中安装Linux Kernel 4.19  https://www.linuxidc.com/Linux/2018-10/155000.htm

Linux kernel 4.18达到了使用寿命,用户需要升级到Linux 4.19  https://www.linuxidc.com/Linux/2018-11/155558.htm

Linux Kernel 4.19发布,初步支持Wi-Fi 6, 新EROFS文件系统  https://www.linuxidc.com/Linux/2018-10/154992.htm

Linux Kernel 的详细介绍请点这里
Linux Kernel 的下载地址请点这里

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2018-12/155747.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款