手机版
你好,游客 登录 注册
背景:
阅读新闻

Systemd 241 发布,安全修复和其他更改

[日期:2019-02-14] 来源:Linux公社  作者:醉落红尘 [字体: ]

Lennart Poettering刚刚标记了systemd 241更新,其中包括“system down”安全修复程序以及对这个广泛使用的Linux init系统的其他改进。

Systemd 241从12月开始成功发布v240,并包含针对“system down”漏洞的修复程序以及常规文件和FIFO保护,systemd-cat的新stderr优先级选项,支持在编译时配置默认语言环境,内核 -  安装脚本现在可以处理多个initrd文件,更好地处理EnvironmentFile设置中的反斜杠,以及NEWS文件中概述的其他更改。

  • 现在可以在编译时配置默认语言环境。 否则,将自动选择合适的默认值(C.UTF-8,en_US.UTF-8和C之一)。
  • systemd和其他工具显示的版本字符串现在包含从git构建时的git commit hash。 可以在编译期间指定覆盖,其旨在由分发使用以包括包发布信息。
  • systemd-cat现在可以使用新的--stderr-priority =选项过滤不同系统日志优先级的标准输入和标准错误流。
  • systemd-journald和systemd-journal-remote拒绝条目,其中包含太多字段(CVE-2018-16865)并对进程的命令行长度设置了限制(CVE-2018-16864)。
  • $ DBUS_SESSION_BUS_ADDRESS环境变量再次由pam_systemd设置。

Systemd 241可以从GitHub中获取。

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2019-02/156904.htm

linux
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款