手机版
你好,游客 登录 注册
背景:
阅读新闻

Mozilla证书过期导致全球Firefox用户无法使用扩展

[日期:2019-05-04] 来源:Linux社区  作者:Linux [字体: ]

今天早上Mozilla和全球的Firefox用户开了个不大不小的玩笑,许多人一大早起来打开浏览器发现微信网页助手、网页截图、标签优化许多流行的浏览器插件都已被禁用了,就连手机版也是如此。重装Firefox或者重装所有的插件都无济于事,在Bugzilla上提交的报告中我们了解到,这是由于Mozilla的官方证书没有及时续期所致。

Mozilla证书过期导致全球Firefox用户无法使用扩展

Mozilla向来在管理证书的方式上与其它友商不太一样,更倾向于自行管理证书或者是自带一套证书系统,这样一来无论是线上服务,还是用户端都提供了更大的自由度,而一旦在管理证书上出现意外,就会导致今天这样尴尬的局面。

Mozilla证书过期导致全球Firefox用户无法使用扩展

无法使用扩展对于Firefox浏览器而言是一大噩梦,尤其是依赖于它开发和调试网页代码的程序员来说更是令人寸步难行。

在Mozilla为他们的证书续期之前,临时的解决方法是打开about:config 页面,搜索xpinstall.signatures.required,将它的值改为false,但这样一来会降低浏览器的安全级别。

Mozilla证书过期导致全球Firefox用户无法使用扩展

Mozilla似乎在整个周末都在处理这个问题,所以对于那些使用Firefox插件的用户来说,希望这个问题能很快得到完全解决。

Linux公社的RSS地址https://www.linuxidc.com/rssFeed.aspx

本文永久更新链接地址https://www.linuxidc.com/Linux/2019-05/158481.htm

linux
相关资讯       Firefox无法使用扩展 
本文评论   查看全部评论 (0)
表情: 表情 姓名: 字数

       

评论声明
  • 尊重网上道德,遵守中华人民共和国的各项有关法律法规
  • 承担一切因您的行为而直接或间接导致的民事或刑事法律责任
  • 本站管理人员有权保留或删除其管辖留言中的任意内容
  • 本站有权在网站内转载或引用您的评论
  • 参与本评论即表明您已经阅读并接受上述条款